Bug 234374 - [panic] page fault in softclock_call_cc -> __rw_wlock_hard on 12.0-RELEASE
Summary: [panic] page fault in softclock_call_cc -> __rw_wlock_hard on 12.0-RELEASE
Status: Closed DUPLICATE of bug 234296
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: panic
Depends on:
Blocks:
 
Reported: 2018-12-24 22:03 UTC by alex
Modified: 2019-02-07 18:28 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex 2018-12-24 22:03:21 UTC
I haven't tried to reproduce this, but I am running a few jails with vimage.
-----------

kernel trap 12 with interrupts disabled


Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual address   = 0x50
fault code              = supervisor write data, page not present
instruction pointer     = 0x20:0xffffffff80bfdf6a
stack pointer           = 0x28:0xfffffe0075d5a560
frame pointer           = 0x28:0xfffffe0075d5a5a0
code segment            = base rx0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = resume, IOPL = 0
current process         = 11 (idle: cpu0)
trap number             = 12
panic: page fault
cpuid = 0
time = 1545662454
KDB: stack backtrace:
#0 0xffffffff80be7977 at kdb_backtrace+0x67
#1 0xffffffff80b9b563 at vpanic+0x1a3
#2 0xffffffff80b9b3b3 at panic+0x43
#3 0xffffffff8107496f at trap_fatal+0x35f
#4 0xffffffff810749c9 at trap_pfault+0x49
#5 0xffffffff81073fee at trap+0x29e
#6 0xffffffff8104f1d5 at calltrap+0x8
#7 0xffffffff80b9655b at __rw_wlock_hard+0xfb
#8 0xffffffff80bb5515 at softclock_call_cc+0xf5
#9 0xffffffff80bb529e at callout_process+0x1ae
#10 0xffffffff811aa358 at handleevents+0x1a8
#11 0xffffffff811aa9c9 at timercb+0xa9
#12 0xffffffff811e8af6 at lapic_handle_timer+0xb6
#13 0xffffffff81050dfe at Xtimerint+0xae
#14 0xffffffff811df68f at cpu_idle_acpi+0x3f
#15 0xffffffff811df747 at cpu_idle+0xa7
#16 0xffffffff80bcfb25 at sched_idletd+0x515
#17 0xffffffff80b5bf33 at fork_exit+0x83
Uptime: 6d2h2m15s
Comment 1 Mark Johnston freebsd_committer 2019-02-07 18:28:30 UTC
This might be a dup of bug 234296, which is fixed by 12.0-p3.  Without a kernel dump it's not really possible to further investigate this panic, so I'll mark the bug a duplicate for now.  Please reopen it if the panic reoccurs on 12.0-p3.

*** This bug has been marked as a duplicate of bug 234296 ***