Bug 234436 - graphics/ufraw does not install if no GUI is configured
Summary: graphics/ufraw does not install if no GUI is configured
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-27 10:45 UTC by Thomas Guymer
Modified: 2019-02-07 16:50 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (rodrigo)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Guymer 2018-12-27 10:45:01 UTC
Building without GTK2 does not create the "ufraw" binary and therefore creates a pkg-static error.

Running "make -C graphics/ufraw showconfig" shows:

===> The following configuration options are available for ufraw-0.22_8:
     CONTRAST=on: Enable contrast setting option
     DST=off: Use local time for timestamps
     EXIV2=on: EXIF and IPTC metadata support via exiv2
     FITS=off: FITS output support
     GIMP=off: Install GIMP plugin
     GNOME=off: GNOME desktop environment support
     GTK2=off: GTK+ 2 GUI toolkit support
     LENSFUN=on: Camera lens database support via LensFun
===> Use 'make config' to modify these settings

Running "portmaster graphics/ufraw" fails with the error:

===>   Registering installation for ufraw-0.22_8
pkg-static: Unable to access file /usr/ports/graphics/ufraw/work/stage/usr/local/bin/ufraw:No such file or directory
*** Error code 74

Running "ls -hl graphics/ufraw/work/stage/usr/local/bin/" shows:

total 1884
-r-xr-xr-x  1 root  staff   409K 27 Dec 10:29 dcraw
-r-xr-xr-x  1 root  staff    27K 27 Dec 10:29 nikon-curve
-r-xr-xr-x  1 root  staff   1.3M 27 Dec 10:29 ufraw-batch

You can see that "ufraw-batch" has been created (which is the binary that I want) and that "ufraw" has not been created (which is the binary that I do not want) which is exactly what I think should've happened. The problem is that the install script thinks that "ufraw" should exist and therefore it fails the whole process even though it is OK for it to be missing.

Thanks,
Comment 1 Rodrigo Osorio freebsd_committer 2019-01-11 14:47:39 UTC
thanks for the report i'm investigating on it
Comment 2 commit-hook freebsd_committer 2019-02-07 11:03:04 UTC
A commit references this bug:

Author: rodrigo
Date: Thu Feb  7 11:02:47 UTC 2019
New revision: 492359
URL: https://svnweb.freebsd.org/changeset/ports/492359

Log:
  Be able to build ufraw without GTK2 option

  Add gnome to the uses to make testport happy
  Bump portrevision

  PR:		234436
  Reported by:	Thomas Guymer <t.m.guymer@thomasguymer.co.uk>

Changes:
  head/graphics/ufraw/Makefile
  head/graphics/ufraw/pkg-plist
Comment 3 Rodrigo Osorio freebsd_committer 2019-02-07 13:57:13 UTC
Committed, thanks
Comment 4 Thomas Guymer 2019-02-07 16:48:35 UTC
It now works great, thank you.
Comment 5 Rodrigo Osorio freebsd_committer 2019-02-07 16:50:39 UTC
(In reply to Thomas Guymer from comment #4)
You're welcome, and by the way thanks for reporting the issue.