Bug 234462 - net-p2p/transmission-daemon silently exits after upgrade dht 0.22 -> 0.25
Summary: net-p2p/transmission-daemon silently exits after upgrade dht 0.22 -> 0.25
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexandre C. Guimarães
URL: https://reviews.freebsd.org/D18660
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-12-28 13:08 UTC by Volodymyr Kostyrko
Modified: 2018-12-30 07:21 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (rigoletto)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volodymyr Kostyrko 2018-12-28 13:08:37 UTC
Hello.

After dht upgrade in bug #233729 transmission-daemon silently exits, I even can't get any logs.
Comment 1 Dries Michiels 2018-12-28 17:09:43 UTC
I have the same problem. When starting transmission it just exists almost immediately without any warnings/errors.
Comment 2 Alexandre C. Guimarães freebsd_committer 2018-12-28 19:20:12 UTC
The fix is in the phab already, I will commit as soon it get approved.

Thanks!
Comment 3 commit-hook freebsd_committer 2018-12-29 07:18:56 UTC
A commit references this bug:

Author: rigoletto
Date: Sat Dec 29 07:18:51 UTC 2018
New revision: 488657
URL: https://svnweb.freebsd.org/changeset/ports/488657

Log:
  net-p2p/tranmission-cli: fix build due to devel/jech-dht update to v0.25.

  - bump PORTREVISION of the affected SLAVEPORTS

  PR:		234462
  Reviewed by:	mat (mentor)
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D18660

Changes:
  head/net-p2p/transmission-cli/Makefile
  head/net-p2p/transmission-cli/files/patch-libtransmission_tr-dht.c
  head/net-p2p/transmission-daemon/Makefile
  head/net-p2p/transmission-gtk/Makefile
  head/net-p2p/transmission-qt/Makefile