Bug 234565 - devel/py-buildbot: Service does not start (WARNING: run_rc_command: cannot run /usr/local/bin/buildbot)
Summary: devel/py-buildbot: Service does not start (WARNING: run_rc_command: cannot ru...
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-02 11:31 UTC by alex
Modified: 2019-03-25 07:35 UTC (History)
0 users

See Also:
koobs: maintainer-feedback? (koobs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex 2019-01-02 11:31:15 UTC
Per below, the service entry is calling the incorrect executable.

# pkg info -Eg '*buildbot*'
py36-buildbot-1.5.0
py36-buildbot-console-view-1.5.0
py36-buildbot-grid-view-1.5.0
py36-buildbot-pkg-1.5.0
py36-buildbot-waterfall-view-1.5.0
py36-buildbot-www-1.5.0
# which buildbot buildbot-3.6
buildbot: Command not found.
/usr/local/bin/buildbot-3.6
# grep ^command /usr/local/etc/rc.d/buildbot
command="/usr/local/bin/buildbot"
# service buildbot start
/usr/local/etc/rc.d/buildbot: WARNING: run_rc_command: cannot run /usr/local/bin/buildbot
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-01-02 11:44:00 UTC
Thank you for the report Alex. Is this a new issue observed after the 1.5.0 upgrade (regression), or on a fresh/first install?
Comment 2 alex 2019-01-02 17:25:06 UTC
This is a fresh install.
Comment 3 commit-hook freebsd_committer 2019-01-04 10:16:18 UTC
A commit references this bug:

Author: koobs
Date: Fri Jan  4 10:16:00 UTC 2019
New revision: 489253
URL: https://svnweb.freebsd.org/changeset/ports/489253

Log:
  devel/py-buildbot: Version-suffix rc script command

  For python ports, particularly those that use USE_PYTHON=concurrent, only
  the *default* python version/flavor (of the port) gets symlinks created for
  any script/binary filenames installed in LOCALBASE/bin.

  For non-default Python versions/flavors of the port or package, *only* a
  version-suffixed script filename is installed.

  The devel/buildbot-worker rc script was fixed in ports r483022 [1] to use a
  version-suffixed script name.

  This change fixes the same for devel/py-buildbot, whos rc script currently
  fails to run due to trying to invoke a non-existent 'buildbot' script name
  for the non-default (!2.7) case.

  Since a port/package cannot know at run time, at any point what the default
  Python version currently is, or whether it has changed, Python ports *must*
  always and only refer to version-specific variants for everything,
  including the Python interpreter, script shebangs, commands, paths, etc,
  for the Python version they are currently being built with.

  PR:		234565, 227675 [1]
  Reported by:	Andreas Sommer <andreas.sommer87 googlemail com>
  MFH:		2019Q1

Changes:
  head/devel/py-buildbot/Makefile
  head/devel/py-buildbot/files/buildbot.in
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2019-01-04 10:20:51 UTC
@Alex Please update your ports tree, reinstall buildbot after ports r489253 to confirm that the issue is resolved. I will wait for your feedback/confirmation before merging to the quarterly branch.
Comment 5 commit-hook freebsd_committer 2019-03-25 07:35:57 UTC
A commit references this bug:

Author: koobs
Date: Mon Mar 25 07:35:00 UTC 2019
New revision: 496797
URL: https://svnweb.freebsd.org/changeset/ports/496797

Log:
  MFH: r489253 devel/py-buildbot: Version-suffix rc script command

  For python ports, particularly those that use USE_PYTHON=concurrent, only
  the *default* python version/flavor (of the port) gets symlinks created for
  any script/binary filenames installed in LOCALBASE/bin.

  For non-default Python versions/flavors of the port or package, *only* a
  version-suffixed script filename is installed.

  The devel/buildbot-worker rc script was fixed in ports r483022 [1] to use a
  version-suffixed script name.

  This change fixes the same for devel/py-buildbot, whos rc script currently
  fails to run due to trying to invoke a non-existent 'buildbot' script name
  for the non-default (!2.7) case.

  Since a port/package cannot know at run time, at any point what the default
  Python version currently is, or whether it has changed, Python ports *must*
  always and only refer to version-specific variants for everything,
  including the Python interpreter, script shebangs, commands, paths, etc,
  for the Python version they are currently being built with.

  PR:		234565, 227675 [1]
  Reported by:	Andreas Sommer <andreas.sommer87 googlemail com>

  Approved by:	ports-secteam (miwi)

Changes:
_U  branches/2019Q1/
  branches/2019Q1/devel/py-buildbot/Makefile
  branches/2019Q1/devel/py-buildbot/files/buildbot.in