Bug 234594 - java/openjdk8: netbeans GUI not updating correctly after recent update
Summary: java/openjdk8: netbeans GUI not updating correctly after recent update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java mailing list
URL:
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2019-01-03 16:42 UTC by Koop Mast
Modified: 2019-02-09 22:57 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (java)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Koop Mast freebsd_committer 2019-01-03 16:42:00 UTC
Since the update of openjdk8-8.192.26_3 the GUI of java/netbeans doesn't refresh correctly anymore. I'm using netbeans 10.0.

This shows up in two ways at are really noticeable:
1) After a while the menu buttons get grayed out, they only update if you move the mouse over them. This is easily reproducible when switching to console and back to X.
2) When a project is opened, the projects window doesn't refresh right away if you unfold a directory (sorry can't think of a better way to describe this). So files in this directory aren't shown. You can force the refresh by scrolling in the window but I think you can agree that this is annoying.

After reverting back to openjdk8-8.181.13_1 these issues go away, so I think this is not a netbeans issue. I'm don't know how to provide more information for debugging this issue.
Comment 1 Stefan Ehmann 2019-01-03 19:39:26 UTC
There seems to be relevant information in ~/.netbeans/10.0/var/log/messages.log:

SEVERE [global]
java.awt.image.ImagingOpException: Unable to convolve src image
    at java.awt.image.ConvolveOp.filter(ConvolveOp.java:198)
    at sun.java2d.pipe.DrawImage.transformImage(DrawImage.java:1108)
    at sun.java2d.pipe.ValidatePipe.transformImage(ValidatePipe.java:238)
    at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:3487)
[...]

There is no such backtrace with the previous openjdk8 version.
Comment 2 Murray 2019-01-22 03:49:39 UTC
A workaround is to deselect the drop-shadow option from the memory graph of the Netbeans10 IDE.(In reply to Koop Mast from comment #0)
Comment 3 Stefan Ehmann 2019-02-09 22:03:10 UTC
I'll do some more testing, but the UI seems to be working fine with openjdk8-8.192.26_5.
Comment 4 Greg Lewis freebsd_committer 2019-02-09 22:57:13 UTC
Sounds like this is now fixed?  Please reopen if you are still having trouble after upgrading to 8.192.26_5.