Bug 234601 - www/tt-rss: Broken web interface after g20181226,1 update
Summary: www/tt-rss: Broken web interface after g20181226,1 update
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thierry Thomas
URL:
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2019-01-03 21:50 UTC by p5B2E9A8F
Modified: 2019-01-16 23:20 UTC (History)
1 user (show)

See Also:
thierry: maintainer-feedback+
koobs: merge-quarterly?


Attachments
tt-rss screenschot prefs.php (51.92 KB, image/png)
2019-01-03 21:50 UTC, p5B2E9A8F
no flags Details
tt-rss screenshot from index.php (49.26 KB, image/png)
2019-01-03 21:53 UTC, p5B2E9A8F
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description p5B2E9A8F 2019-01-03 21:50:57 UTC
Created attachment 200751 [details]
tt-rss screenschot prefs.php

After upgrade to tt-rss-g20181226,1 the web interface is broken.
While functionality seems to be ok, there are missing web elements.
See attached screenshots.
Comment 1 p5B2E9A8F 2019-01-03 21:53:43 UTC
Created attachment 200752 [details]
tt-rss screenshot from index.php
Comment 2 Thierry Thomas freebsd_committer 2019-01-09 20:51:30 UTC
Sorry, I cannot see such a regression on my site.

- Which browser do you use?

- Have you enabled any add_on or some theme?

- Any interesting messages in /var/log/httpd-* ?

There is a support page for Tiny Tiny RSS, located at
https://discourse.tt-rss.org/c/tiny-tiny-rss/support
and I have not found such a problem...

Waiting for more details.
Comment 3 p5B2E9A8F 2019-01-10 20:02:24 UTC
The problem is caused when in Firefox "Allow pages to choose their own fonts" is disabled. This can easily be reproduced.

The new tt-rss version obviously makes use of such instead of a less "smart" solution. This is a problem for those who need this feature to be disabled for a good reason.

Just enabling such fonts is no workaround, as that would allow 3rd party fonts generally.

A patch would be using png icons instead of using a font.
Comment 4 Thierry Thomas freebsd_committer 2019-01-10 20:21:32 UTC
(In reply to p5B2E9A8F from comment #3)

OK, I see! Thanks for the follow-up.

But this is not a problem caused by this port or FreeBSD: it won't be solved by a local patch, but by a modification of the upstream code - if they agree.

So I suggest that you report this problem to the Tiny Tiny RSS developer.