Bug 234606 - FreeBSD 12.0 install from DVD aborts (UEFI/GPT HDD multiboot)
Summary: FreeBSD 12.0 install from DVD aborts (UEFI/GPT HDD multiboot)
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 12.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-01-04 10:17 UTC by Silvio Arnone
Modified: 2020-01-25 15:38 UTC (History)
2 users (show)

See Also:


Attachments
lshw.log (24.67 KB, text/plain)
2019-01-04 10:23 UTC, Kubilay Kocak
no flags Details
screenshot before reboot (649.50 KB, image/jpeg)
2019-01-04 10:29 UTC, Kubilay Kocak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio Arnone 2019-01-04 10:17:00 UTC
Dear Sirs,

I am an absolute FreeBSD beginner and am writing here after suggestion got in the Forum. Briefing: as in the title, DVD and image stick install process aborts some lines after process starts and machine automatically reboots showing GRUB2.
Better than words a short video can show you what I mean, here:
https://drive.google.com/file/d/15xmKyqZrHvLfrjUj02d0Xg6_b0TX0BrJ/view?usp=sharing

Thread in the Forum here:
https://forums.freebsd.org/threads/freebsd-12-0-install-from-dvd-aborts.68960/

lshw machine here:
https://pastebin.com/nGx5K1NA

Two HDD on the machine: /dev/sda = only Windows 10
                        /dev/sdb = Linux GPT partitions ext4
                       (plus or minus 70 GB each plus NTFS for data, efi and swap) 

If needing more data, please, let me know.

Best Regards

Silvio Arnone
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-01-04 10:23:23 UTC
Created attachment 200761 [details]
lshw.log

Attaching lwhw.log (from pastebin) so the information is self contained in this issue.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-01-04 10:29:05 UTC
Created attachment 200762 [details]
screenshot before reboot

Attaching a screenshot of the screen before the automatic reboot, so the information is all self-contained in this issue
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-01-04 10:30:49 UTC
@Silvio, Can you detail exactly which DVD ISO (full filename) image you you downloaded and whether you have tried any others?

If you haven't tried any others, I would attempt the bootonly and memstick images, if nothing else than to give us a couple of more datapoints
Comment 5 Bernd Roth 2020-01-25 15:38:57 UTC
Hello, I'm on a Supermicro A2SDi-8C+-HLN4F + 16GB RAM with 11-RELEASE installation that was upgraded to 12.0 RELEASE via freebsd-update. I did the update to 12.1 before christmas but i think i haven't done a reboot because my latest known uptime was approx. 180 days. I learned about rc.local now and tested my setup via shutdown -r and after that i got the same failure structure as seen on the https://bugs.freebsd.org/bugzilla/attachment.cgi?id=200762 - system freeze after the EFI framebuffer information lines; ending with "masks 0x...".

Still in operator PANIC mode i've got FreeBSD-12.1-RELEASE-amd64-memstick.img up and running and managed to reduce rc.conf to minimum modules and to get write access to /boot/loader.conf which is 

verbose_loading="YES"

now. I also tried kern.vty=sc, hw.vga.textmode=1, but with no help. The system still freeze after the masks line. I found some other logfiles and the next line after the masks line usually may be ---<<BOOT>>--- which is not seen here. I noticed most of the memstick loader files in /boot/ are dated nov 01 05:14 while some of my loader files are dec 10 10:40 and others are feb 15 2019. Meanwhile i extracted base.txz and kernel.txz from the image above into the sytem without success.

I noticed i have 2 kernel and changed to the other one. I see it's /boot/kernel.old/kernel now but it still freezes.

Please recheck bug report header. If this is valid to be the same bug then it does affect me too.