Bug 234646 - kldload radeon kms - black screen
Summary: kldload radeon kms - black screen
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
Depends on:
Reported: 2019-01-05 23:01 UTC by lumiwa
Modified: 2020-01-30 00:44 UTC (History)
4 users (show)

See Also:
lumiwa: maintainer-feedback? (jmd)

xorg.log and part of /var/log/messages (35.42 KB, text/plain)
2019-01-05 23:01 UTC, lumiwa
no flags Details
try to use drm-fbsd11.2-kmod from ports with atilegacy (32.98 KB, text/plain)
2019-01-07 23:22 UTC, lumiwa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lumiwa 2019-01-05 23:01:38 UTC
Created attachment 200816 [details]
xorg.log and part of /var/log/messages

My system is FreeBSD 12.0-RELEASE (amd640), new installed on the new hard drive.
Computer is iMac with Radeom 4850 graphics card, the boot is UEFI and everything works except graphics card problem.
When I kldload /boot/modules/radeonkms.ko I got black screen and computer is still responsive.
I try also to boot computer with  hw.syscons.disable=1 in /boot/loader.conf and in /etc/rc.conf I have kldload /boot/modules/radeonkms.ko
and again black screen.
I have installed drm-legacy-kmod and xf86-video-ati-legacy but I tried also with new ati driver and drm for 12 and the same result.
On the old system when I use ati driver version 7.9 and kldload radeon.ko from kernel worked without problem. On the old system the new ATI driver didn't work and none of the drm-kmod didn't work too.
Now I am using scfb driver and it works.
I do not know if is a bug in the drivers or something else.

Thank you.

Please check attached logs.
Comment 1 lumiwa 2019-01-07 23:22:13 UTC
Created attachment 200894 [details]
try to use drm-fbsd11.2-kmod from ports with atilegacy

I deinstall drm-legacy-kmod and install drm-fbsd11.2-kmod but again black screen.
Please, check attaced logs.
Comment 2 lumiwa 2019-01-27 16:22:14 UTC
I did try to run FreeBSD 11.2 on the borrowed dock station and it boot (slow but...) and everything was O.K. - no black screen when switched to fb. I did also "startx" and open Openbox.
The difference from the new system is that on the old drive I had freebsd-boot and uefi partitions but on the new one I have just uefi.
Comment 3 Chris Rees freebsd_committer 2020-01-17 20:10:32 UTC
The black screen, this only happens when Xorg is running?
Comment 4 Sean Farley freebsd_committer 2020-01-30 00:44:27 UTC
(In reply to Chris Rees from comment #3)

I think this happened to me after upgrading a 12-STABLE system from r354521 to r357245.  However, my system is unresponsive at this point.

Rebuilding the modules did not help until I upgraded the poudriere jail from 12.1-STABLE (maybe r354521?) to r357245.  Some KBI changed between the two revisions?

It happened without Xorg at the moment radeonkms.ko was loaded.

vgapci0@pci0:1:0:0:     class=0x030000 card=0x02721028 chip=0x94881002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'RV730/M96-XT [Mobility Radeon HD 4670]'
    class      = display
    subclass   = VGA
    bar   [10] = type Prefetchable Memory, range 32, base rxd0000000, size 268435456, enabled
    bar   [14] = type I/O Port, range 32, base rx2000, size 256, enabled
    bar   [18] = type Memory, range 32, base rxcfef0000, size 65536, enabled
    cap 01[50] = powerspec 3  supports D0 D1 D2 D3  current D0
    cap 10[58] = PCI-Express 2 legacy endpoint max data 128(128) RO NS
                 link x16(x16) speed 2.5(2.5) ASPM L0s/L1(L0s/L1)
    cap 05[a0] = MSI supports 1 message, 64 bit enabled with 1 message
    ecap 000b[100] = Vendor 1 ID 1
    PCI errors = Signalled System Error
  PCI-e errors = Non-Fatal Error Detected
                 Unsupported Request Detected