Bug 234660 - lang/perl5.26 detects wrong version
Summary: lang/perl5.26 detects wrong version
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-06 10:50 UTC by emu
Modified: 2019-01-06 20:08 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emu 2019-01-06 10:50:17 UTC
Clean install of FreeBSD 12-RELEASE
portsnap fetch
portsnap extract


Trying to install perl modules errors with:
env: /usr/local/bin/perl5.26.3: No such file or directory

The perl version on the system is v5.26.2


Example:
root@bsd01:/usr/ports/devel/p5-LockFile-Simple # make install
===>   p5-LockFile-Simple-0.208 depends on package: perl5>=5.26<5.27 - found
===>  Configuring for p5-LockFile-Simple-0.208
env: /usr/local/bin/perl5.26.3: No such file or directory
*** Error code 127

Stop.
make: stopped in /usr/ports/devel/p5-LockFile-Simple
root@bsd01:/usr/ports/devel/p5-LockFile-Simple # perl -v

This is perl 5, version 26, subversion 2 (v5.26.2) built for amd64-freebsd-thread-multi
Comment 1 Niclas Zeising freebsd_committer 2019-01-06 20:08:40 UTC
Pass to mat, maintainer of perl 5.26.