Bug 234682 - x11/polybar : fails to build with DEFAULT_VERSIONS=python=3.x
Summary: x11/polybar : fails to build with DEFAULT_VERSIONS=python=3.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexandre C. Guimarães
URL: https://reviews.freebsd.org/D18770
Keywords:
Depends on:
Blocks: 234633
  Show dependency treegraph
 
Reported: 2019-01-07 06:31 UTC by Antoine Brodin
Modified: 2019-01-13 22:00 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (rigoletto)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Brodin freebsd_committer 2019-01-07 06:31:11 UTC
portmgr@ plans to make python3.6 default version of python in the next weeks.

x11/polybar fails to build with DEFAULT_VERSIONS=python=3.x

Failure log:

http://package23.nyi.freebsd.org/data/112i386-default-PR234633/2019-01-05_13h25m51s/logs/errors/polybar-3.3.0.log
Comment 1 Alexandre C. Guimarães freebsd_committer 2019-01-13 22:00:42 UTC
Thanks! ^^
Comment 2 commit-hook freebsd_committer 2019-01-13 22:00:45 UTC
A commit references this bug:

Author: rigoletto
Date: Sun Jan 13 22:00:12 UTC 2019
New revision: 490217
URL: https://svnweb.freebsd.org/changeset/ports/490217

Log:
  x11/polybar: fix build with DEFAULT_VERSIONS=python=3.x

  PR:		234682
  Reported by:	antoine
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D18770

Changes:
  head/x11/polybar/Makefile
  head/x11/polybar/files/patch-lib_xpp_CMakeLists.txt