Bug 234690 - sh(1): segmentation fault on "bind"
Summary: sh(1): segmentation fault on "bind"
Status: Closed DUPLICATE of bug 233343
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-07 13:06 UTC by Edward Tomasz Napierala
Modified: 2019-01-07 13:15 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Tomasz Napierala freebsd_committer 2019-01-07 13:06:28 UTC
Setting PS1 to a string containing "`whoami`" seems to make sh(1) crash when executing the "bind" command, without arguments.  For example:

$ bind                              
Standard key bindings            
"^@"           ->  em-set-mark 
"^A"           ->  ed-move-to-beg 

[..]

$ PS1="`whoami`@\h:\w \\$ "
trasz@v2:~ $ bind
zsh: segmentation fault (core dumped)  sh

Backtrace looks like this:

(gdb) run
Starting program: /bin/sh
$ PS1="`whoami`@\h:\w \\$ "
[Detaching after fork from child process 3038]
trasz@v2:~ $ bind

Program received signal SIGSEGV, Segmentation fault.
map_bind (el=<optimized out>, argc=<optimized out>, argv=0x800a08028) at /usr/home/trasz/svn/head/lib/libedit/map.c:1271
1271                    if (p[0] == '-')
(gdb) bt
#0  map_bind (el=<optimized out>, argc=<optimized out>, argv=0x800a08028) at /usr/home/trasz/svn/head/lib/libedit/map.c:1271
#1  0x00000008002919a0 in el_wparse (el=0x800a3d000, argc=<optimized out>, argv=<optimized out>) at /usr/home/trasz/svn/head/lib/libedit/parse.c:132
#2  0x000000080029167a in el_parse (el=0x800a3d000, argc=1, argv=<optimized out>) at /usr/home/trasz/svn/head/lib/libedit/eln.c:101
#3  0x000000000020ed56 in evalcommand (cmd=0x800a38230, flags=0, backcmd=0x0) at /usr/home/trasz/svn/head/bin/sh/eval.c:1107
#4  0x000000000020d80b in evaltree (n=0x800a38230, flags=0) at /usr/home/trasz/svn/head/bin/sh/eval.c:289
#5  0x0000000000219958 in cmdloop (top=1) at /usr/home/trasz/svn/head/bin/sh/main.c:220
#6  0x00000000002197e4 in main (argc=1, argv=0x7fffffffea20) at /usr/home/trasz/svn/head/bin/sh/main.c:167
Comment 1 Jilles Tjoelker freebsd_committer 2019-01-07 13:15:16 UTC

*** This bug has been marked as a duplicate of bug 233343 ***