Bug 234703 - net-p2p/py-tremc suddenly missing GeoIP
Summary: net-p2p/py-tremc suddenly missing GeoIP
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexandre C. Guimarães
URL: https://bugs.freebsd.org/bugzilla/sho...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-07 18:56 UTC by huber.georg
Modified: 2019-01-08 17:01 UTC (History)
0 users

See Also:
rigoletto: maintainer-feedback+


Attachments
Remove GeoIP option. (907 bytes, patch)
2019-01-08 15:40 UTC, Alexandre C. Guimarães
rigoletto: maintainer-approval+
Details | Diff
Remove GeoIP and add IPY OPTIONS. (1.01 KB, patch)
2019-01-08 16:16 UTC, Alexandre C. Guimarães
rigoletto: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description huber.georg 2019-01-07 18:56:19 UTC
Hi,

Since the latest update, starting tremc gets me:

Error Opening file /usr/local/share/GeoIP/GeoIP.dat
Traceback (most recent call last):
  File "/usr/local/bin/tremc", line 3718, in <module>
    config.get('Connection', 'password'))
  File "/usr/local/bin/tremc", line 365, in __init__
    self.geo_ip = GeoIP.new(GeoIP.GEOIP_MEMORY_CACHE)
GeoIP.error: [Errno 2] No such file or directory: '/usr/local/share/GeoIP/GeoIP.dat'



/usr/local/share/GeoIP/ is empty.

GeoIP-1.6.12_1 and py36-GeoIP-1.3.2_1 are installed.

When I run geoipupdate.sh it won't download anything, as apparently the URL in the .sh file is no longer working.

I recompiled tremc _without_ GeoIP support, still it gives me the same error.

Do you have any idea what I could be doing wrong?

Thanks
Comment 1 Alexandre C. Guimarães freebsd_committer 2019-01-07 20:16:41 UTC
Hi.

Basically Maxmind is not providing that file anymore. I will contact the GeoIP maintainer about that.

Tremc still break when the GEOIP option is off because it is the typical python software, and the dependencies are run time. If you remove the `net/GeoIP` package from your system it should work fine.

For now I will remove GEOIP from the default options.

Thank you for reporting.
Comment 2 Alexandre C. Guimarães freebsd_committer 2019-01-08 15:36:46 UTC
Given the necessary GeoIP is now legacy by upstream and also deprecated in ports, I will remove that OPTION completely (at least until Tremc acquire the same function using another component).
Comment 3 Alexandre C. Guimarães freebsd_committer 2019-01-08 15:40:02 UTC
Created attachment 200918 [details]
Remove GeoIP option.
Comment 4 Alexandre C. Guimarães freebsd_committer 2019-01-08 16:16:35 UTC
Created attachment 200919 [details]
Remove GeoIP and add IPY OPTIONS.
Comment 5 Alexandre C. Guimarães freebsd_committer 2019-01-08 17:00:16 UTC
Thanks! :-)
Comment 6 commit-hook freebsd_committer 2019-01-08 17:00:40 UTC
A commit references this bug:

Author: rigoletto
Date: Tue Jan  8 17:00:06 UTC 2019
New revision: 489724
URL: https://svnweb.freebsd.org/changeset/ports/489724

Log:
  net-p2p/py-tremc: remove the broken GeoIP option

  - add IPY option (extract ipv4 from ipv6 addresses)

  PR:		234703
  Reported by:	huber.georg@gmail.com
  Approved by:	tcberner (mentor)

Changes:
  head/net-p2p/py-tremc/Makefile