Bug 234748 - devel/RStudio fails to build in poudriere on 12/Stable amd64
Summary: devel/RStudio fails to build in poudriere on 12/Stable amd64
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-08 14:39 UTC by Robert Cina
Modified: 2019-01-10 00:09 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments
devel/RStudio poudriere build log with error (969.74 KB, text/plain)
2019-01-08 14:39 UTC, Robert Cina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2019-01-08 14:39:52 UTC
Created attachment 200912 [details]
devel/RStudio poudriere build log with error

The port devel/RStudio fails to build on 12/Stable on amd64 using poudriere for me. I have attached the poudriere build log but the port throws an exception while rebinding as shown below: 

ext:
   [jscomp] None of the files changed. Compilation skipped.

javac:
    [javac] Compiling 1 source file to /wrkdirs/usr/ports/devel/RStudio/work/rstudio-1.2.679/src/gwt/bin

gwtc:
     [java] Compiling module org.rstudio.studio.RStudio
     [java]    Computing all possible rebind results for 'org.rstudio.studio.client.workbench.views.vcs.dialog.DiffFrame.Resources'
     [java]       Rebinding org.rstudio.studio.client.workbench.views.vcs.dialog.DiffFrame.Resources
     [java]          Invoking generator com.google.gwt.resources.rebind.context.InlineClientBundleGenerator
     [java]             [ERROR] Generator 'com.google.gwt.resources.rebind.context.InlineClientBundleGenerator' threw an exception while rebinding 'org.rstudio.studio.client.workbench.views.vcs.dialog.DiffFrame.Resources'
     [java] java.lang.NullPointerException
     [java] 	at com.google.gwt.dev.util.Util.computeStrongName(Util.java:119)
     [java] 	at com.google.gwt.dev.util.Util.computeStrongName(Util.java:94)
     [java] 	at com.google.gwt.resources.rg.ImageResourceGenerator$LocalizedImage.key(ImageResourceGenerator.java:428)
     [java] 	at com.google.gwt.resources.rg.ImageResourceGenerator$LocalizedImage.<init>(ImageResourceGenerator.java:440)
     [java] 	at com.google.gwt.resources.rg.ImageResourceGenerator$LocalizedImage.create(ImageResourceGenerator.java:423)
Comment 1 Robert Cina 2019-01-10 00:01:59 UTC
After updating my poudriere ports devel/RStudio seems to build correctly again.  I don't know the reason the reason why it is fixed now but I am happy it works again. 

Thanks
Comment 2 Yuri Victorovich freebsd_committer 2019-01-10 00:09:00 UTC
You need MAX_FILES_RStudio=2048 in poudriere.conf.

RStudio runs out of file descriptors.

Yuri