Bug 234762 - www/node: refuses to build with system openssl on 12.x
Summary: www/node: refuses to build with system openssl on 12.x
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bradley T. Hughes
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-08 18:21 UTC by Dmitry Marakasov
Modified: 2019-01-08 18:21 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bhughes)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2019-01-08 18:21:01 UTC
/usr/ports/www/node % WITHOUT=BUNDLED_SSL make    
===>  node-11.6.0 node.js requires openssl 1.1.0, add
DEFAULT_VERSIONS+=ssl=openssl111 to /etc/make.conf or enable BUNDLED_SSL
option.
*** Error code 1

This IGNORE is incorrect, as FreeBSD 12+ indeed has new openssl