Bug 234780 - science/agrum : fails to package with DEFAULT_VERSIONS=python=3.x
Summary: science/agrum : fails to package with DEFAULT_VERSIONS=python=3.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks: 234633
  Show dependency treegraph
 
Reported: 2019-01-09 10:20 UTC by Antoine Brodin
Modified: 2019-01-09 11:04 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Brodin freebsd_committer 2019-01-09 10:20:40 UTC
portmgr@ plans to make python3.6 default version of python in the next weeks.

science/agrum fails to package with DEFAULT_VERSIONS=python=3.x

Failure log:

http://package23.nyi.freebsd.org/data/112i386-default-PR234633/2019-01-08_06h30m30s/logs/errors/agrum-0.13.4_2.log
Comment 1 Yuri Victorovich freebsd_committer 2019-01-09 11:04:47 UTC
Fixed.
Comment 2 commit-hook freebsd_committer 2019-01-09 11:04:53 UTC
A commit references this bug:

Author: yuri
Date: Wed Jan  9 11:04:38 UTC 2019
New revision: 489768
URL: https://svnweb.freebsd.org/changeset/ports/489768

Log:
  science/agrum: Fix build for python 3.x

  PR:		234780
  Reported by:	antoine

Changes:
  head/science/agrum/Makefile
  head/science/agrum/pkg-plist