Bug 234809 - lib/libc/sys/sendfile_test:hdtr_positive_test fails due to a mismatch in expected vs actual data from calls
Summary: lib/libc/sys/sendfile_test:hdtr_positive_test fails due to a mismatch in expe...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: Enji Cooper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-10 00:49 UTC by Enji Cooper
Modified: 2019-03-10 16:16 UTC (History)
1 user (show)

See Also:
ngie: mfc-stable11+
ngie: mfc-stable12+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2019-01-10 00:49:04 UTC
Proactive bug being filed for testcases being added in D18625, per asomers's request:

$ kyua debug -k /usr/tests/lib/libc/sys/Kyuafile sendfile_test:hdtr_positive_v4
Generating a random port with seed=2
Port range lower bound: 10000
Port range upper bound: 65535
Random port generated: 60420
Will try to bind socket to host='127.0.0.1', address_family=2, socket_type=1
Will try to connect to host='127.0.0.1', address_family=2, socket_type=1
Generating a random port with seed=2
Port range lower bound: 10000
Port range upper bound: 65535
Random port generated: 60420
Will try to bind socket to host='127.0.0.1', address_family=2, socket_type=1
Will try to connect to host='127.0.0.1', address_family=2, socket_type=1
dest_file: This is a headerThe past is already gone, the future is not yet here. There's only one moment for you to live.
Will mmap in the source file from offset=0 to length=111
Generating a random port with seed=686
Random port generated: 60663
Will try to bind socket to host='127.0.0.1', address_family=2, socket_type=1
Will try to connect to host='127.0.0.1', address_family=2, socket_type=1
Generating a random port with seed=2
Port range lower bound: 10000
Port range upper bound: 65535
Random port generated: 60420
Will try to bind socket to host='127.0.0.1', address_family=2, socket_type=1
Will try to connect to host='127.0.0.1', address_family=2, socket_type=1
dest_file: This is a headerThe past is already gone, the future is not yet here. There's only one moment for you to live.
Will mmap in the source file from offset=0 to length=111
Generating a random port with seed=686
Random port generated: 60663
Will try to bind socket to host='127.0.0.1', address_family=2, socket_type=1
Will try to connect to host='127.0.0.1', address_family=2, socket_type=1
subprocess stderr: sendfile_test: received unexpected data: This is a trailerdy gone, the future is not yet here. There's only one moment for you to live.
subprocess stderr: 
sendfile_test:hdtr_positive_v4  ->  expected_failure: the header/trailer testcases fail today: /usr/src/contrib/atf/atf-c/utils.c:431: exitstatus != WEXITSTATUS(status)
Comment 1 commit-hook freebsd_committer 2019-02-19 22:20:21 UTC
A commit references this bug:

Author: ngie
Date: Tue Feb 19 22:19:32 UTC 2019
New revision: 344310
URL: https://svnweb.freebsd.org/changeset/base/344310

Log:
  Make `server_cat(..)` handle short receives

  In short, the prior code was far too simplistic when it came to calling recv(2)
  and failed intermittently (or in the case of Jenkins, deterministically).

  Handle short recv(2)s by checking the return code and incrementing the window
  into the buffer by the number of received bytes. If the number of received
  bytes <= 0, then bail out of the loop, and test the total number of received
  bytes vs the expected number of bytes sent for equality, and base whether or
  not the test passes/fails on that fact.

  Remove the expected failure, now that the hdtr testcases deterministically pass
  on my host after this change [1].

  PR:		234809 [1], 235200
  Reviewed by:	asomers
  Approved by:	emaste (mentor)
  MFC after:	1 week
  Differential Revision: https://reviews.freebsd.org/D19188

Changes:
  head/lib/libc/tests/sys/sendfile_test.c
Comment 2 commit-hook freebsd_committer 2019-03-10 16:13:50 UTC
A commit references this bug:

Author: ngie
Date: Sun Mar 10 16:13:01 UTC 2019
New revision: 344977
URL: https://svnweb.freebsd.org/changeset/base/344977

Log:
  MFC r343362,r343365,r343367,r343368,r343461,r343751,r344310:

  r343362:

  Add [initial] functional tests for sendfile(2) as lib/libc/sys/sendfile

  These testcases exercise a number of functional requirements for sendfile(2).

  The testcases use IPv4 and IPv6 domain sockets with TCP, and were confirmed
  functional on UFS and ZFS. UDP address family sockets cannot be used per the
  sendfile(2) contract, thus using UDP sockets is outside the scope of
  testing the syscall in positive cases. As seen in
  `:s_negative_udp_socket_test`, UDP is used to test the sendfile(2) contract
  to ensure that EINVAL is returned by sendfile(2).

  The testcases added explicitly avoid testing out `SF_SYNC` due to the
  complexity of verifying that support. However, this is a good next logical
  item to verify.

  The `hdtr_positive*` testcases work to a certain degree (the header
  testcases pass), but the trailer testcases do not work (it is an expected
  failure). In particular, the value received by the mock server doesn't match
  the expected value, and instead looks something like the following (using
  python array notation):

  `trailer[:]message[1:]`

  instead of:

  `message[:]trailer[:]`

  This makes me think there's a buffer overrun issue or problem with the
  offset somewhere in the sendfile(2) system call, but I need to do some
  other testing first to verify that the code is indeed sane, and my
  assumptions/code isn't buggy.

  The `sbytes_negative` testcases that check `sbytes` being set to an
  invalid value resulting in `EFAULT` fails today as the other change
  (which checks `copyout(9)`) has not been committed [1]. Thus, it
  should remain an expected failure (see bug 232210 for more details
  on this item).

  Next steps for testing sendfile(2):
  1. Fix the header/trailer testcases so that they pass.
  2. Setup if_tap interface and test with it, instead of using "localhost", per
     @asomers's suggestion.
  3. Handle short recv(2)'s in `server_cat(..)`.
  4. Add `SF_SYNC` support.
  5. Add some more negative tests outside the scope of the functional contract.

  PR: 		232210

  r343365:

  Unbreak the gcc build with sendfile_test after r343362

  gcc 8.x is more pedantic than clang 7.x with format strings and the tests
  passed `void*` variables while supplying `%s` (which is technically
  incorrect).

  Make the affected `void*` variables use `char*` storage instead to address
  this issue, as the compiler will upcast the values to `char*`.

  MFC with:	r343362

  r343367:

  Unbreak the build on architectures where size_t isn't synonymous with uintmax_t

  I should have used `%zu` instead of `%ju` with `size_t` types.

  MFC with:	r343362, r343365
  Pointyhat to:	ngie

  r343368:

  Fix up r343367

  I should have only changed the format qualifier with the `size_t` value,
  `length`, not the other [`off_t`] value, `dest_file_size`.

  MFC with:	r343362, r343365, r343367

  r343461:

  Fix reporting errors with `gai_strerror(..)`

  The return value (`err`) should be checked; not the `errno` value.

  PR:		235200
  MFC with:	r343362, r343365, r343367-r343368

  r343751:

  Avoid the DNS lookup for "localhost"

  ci.FreeBSD.org does not have access to a DNS resolver/network (unlike my test
  VM), so in order for the test to pass on the host, it needs to avoid the DNS
  lookup by using the numeric host address representation.

  PR:		235200
  MFC with:	r343362, r343365, r343367-r343368, r343461

  r344310:

  Make `server_cat(..)` handle short receives

  In short, the prior code was far too simplistic when it came to calling recv(2)
  and failed intermittently (or in the case of Jenkins, deterministically).

  Handle short recv(2)s by checking the return code and incrementing the window
  into the buffer by the number of received bytes. If the number of received
  bytes <= 0, then bail out of the loop, and test the total number of received
  bytes vs the expected number of bytes sent for equality, and base whether or
  not the test passes/fails on that fact.

  Remove the expected failure, now that the hdtr testcases deterministically pass
  on my host after this change [1].

  PR:		234809 [1], 235200

  Approved by:	emaste (mentor)
  Differential Revision: https://reviews.freebsd.org/D19524

Changes:
_U  stable/11/
  stable/11/lib/libc/tests/sys/Makefile
  stable/11/lib/libc/tests/sys/sendfile_test.c
Comment 3 commit-hook freebsd_committer 2019-03-10 16:15:01 UTC
A commit references this bug:

Author: ngie
Date: Sun Mar 10 16:14:43 UTC 2019
New revision: 344978
URL: https://svnweb.freebsd.org/changeset/base/344978

Log:
  MFC r343362,r343365,r343367,r343368,r343461,r343751,r344310:

  r343362:

  Add [initial] functional tests for sendfile(2) as lib/libc/sys/sendfile

  These testcases exercise a number of functional requirements for sendfile(2).

  The testcases use IPv4 and IPv6 domain sockets with TCP, and were confirmed
  functional on UFS and ZFS. UDP address family sockets cannot be used per the
  sendfile(2) contract, thus using UDP sockets is outside the scope of
  testing the syscall in positive cases. As seen in
  `:s_negative_udp_socket_test`, UDP is used to test the sendfile(2) contract
  to ensure that EINVAL is returned by sendfile(2).

  The testcases added explicitly avoid testing out `SF_SYNC` due to the
  complexity of verifying that support. However, this is a good next logical
  item to verify.

  The `hdtr_positive*` testcases work to a certain degree (the header
  testcases pass), but the trailer testcases do not work (it is an expected
  failure). In particular, the value received by the mock server doesn't match
  the expected value, and instead looks something like the following (using
  python array notation):

  `trailer[:]message[1:]`

  instead of:

  `message[:]trailer[:]`

  This makes me think there's a buffer overrun issue or problem with the
  offset somewhere in the sendfile(2) system call, but I need to do some
  other testing first to verify that the code is indeed sane, and my
  assumptions/code isn't buggy.

  The `sbytes_negative` testcases that check `sbytes` being set to an
  invalid value resulting in `EFAULT` fails today as the other change
  (which checks `copyout(9)`) has not been committed [1]. Thus, it
  should remain an expected failure (see bug 232210 for more details
  on this item).

  Next steps for testing sendfile(2):
  1. Fix the header/trailer testcases so that they pass.
  2. Setup if_tap interface and test with it, instead of using "localhost", per
     @asomers's suggestion.
  3. Handle short recv(2)'s in `server_cat(..)`.
  4. Add `SF_SYNC` support.
  5. Add some more negative tests outside the scope of the functional contract.

  PR: 		232210

  r343365:

  Unbreak the gcc build with sendfile_test after r343362

  gcc 8.x is more pedantic than clang 7.x with format strings and the tests
  passed `void*` variables while supplying `%s` (which is technically
  incorrect).

  Make the affected `void*` variables use `char*` storage instead to address
  this issue, as the compiler will upcast the values to `char*`.

  MFC with:	r343362

  r343367:

  Unbreak the build on architectures where size_t isn't synonymous with uintmax_t

  I should have used `%zu` instead of `%ju` with `size_t` types.

  MFC with:	r343362, r343365
  Pointyhat to:	ngie

  r343368:

  Fix up r343367

  I should have only changed the format qualifier with the `size_t` value,
  `length`, not the other [`off_t`] value, `dest_file_size`.

  MFC with:	r343362, r343365, r343367

  r343461:

  Fix reporting errors with `gai_strerror(..)`

  The return value (`err`) should be checked; not the `errno` value.

  PR:		235200
  MFC with:	r343362, r343365, r343367-r343368

  r343751:

  Avoid the DNS lookup for "localhost"

  ci.FreeBSD.org does not have access to a DNS resolver/network (unlike my test
  VM), so in order for the test to pass on the host, it needs to avoid the DNS
  lookup by using the numeric host address representation.

  PR:		235200
  MFC with:	r343362, r343365, r343367-r343368, r343461

  r344310:

  Make `server_cat(..)` handle short receives

  In short, the prior code was far too simplistic when it came to calling recv(2)
  and failed intermittently (or in the case of Jenkins, deterministically).

  Handle short recv(2)s by checking the return code and incrementing the window
  into the buffer by the number of received bytes. If the number of received
  bytes <= 0, then bail out of the loop, and test the total number of received
  bytes vs the expected number of bytes sent for equality, and base whether or
  not the test passes/fails on that fact.

  Remove the expected failure, now that the hdtr testcases deterministically pass
  on my host after this change [1].

  PR:		234809 [1], 235200

  Approved by:	emaste (mentor, implicit: MFC to ^/stable/11 in r344977)
  Differential Revision: https://reviews.freebsd.org/D19523

Changes:
_U  stable/12/
  stable/12/lib/libc/tests/sys/Makefile
  stable/12/lib/libc/tests/sys/sendfile_test.c