Bug 234818 - multimedia/transcode: Fix build on i386 with lld linker
Summary: multimedia/transcode: Fix build on i386 with lld linker
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Some People
Assignee: Thomas Zander
URL:
Keywords: patch
: 234862 (view as bug list)
Depends on:
Blocks: 214864
  Show dependency treegraph
 
Reported: 2019-01-10 11:46 UTC by Thomas Zander
Modified: 2019-01-19 17:21 UTC (History)
2 users (show)

See Also:
cyberbotx: maintainer-feedback+


Attachments
Fix for lld on i386 (334 bytes, text/plain)
2019-01-10 11:46 UTC, Thomas Zander
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Zander freebsd_committer 2019-01-10 11:46:24 UTC
Created attachment 200982 [details]
Fix for lld on i386

HEAD will move to lld as default linker on i386 soonish, see bug #214864.

Attached patch fixes the associated build problem with transcode
Comment 1 Naram Qashat 2019-01-14 04:17:00 UTC
Patch is acceptable to me.
Comment 2 Ed Maste freebsd_committer 2019-01-14 05:02:41 UTC
*** Bug 234862 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2019-01-19 17:16:39 UTC
A commit references this bug:

Author: riggs
Date: Sat Jan 19 17:15:53 UTC 2019
New revision: 490725
URL: https://svnweb.freebsd.org/changeset/ports/490725

Log:
  Fix build on i386 with lld linker

  PR:		234818
  Submitted by:	riggs
  Approved by:	cyberbotx@cyberbotx.com (maintainer)

Changes:
  head/multimedia/transcode/Makefile