Bug 234819 - net-im/licq-qt-gui: Remove qt5-buildtools run dependency
Summary: net-im/licq-qt-gui: Remove qt5-buildtools run dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2019-01-10 11:53 UTC by Tobias Kortkamp
Modified: 2019-01-19 14:55 UTC (History)
1 user (show)

See Also:
dinoex: maintainer-feedback+


Attachments
licq-qt-gui.diff (790 bytes, patch)
2019-01-10 11:53 UTC, Tobias Kortkamp
tobik: maintainer-approval? (dinoex)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2019-01-10 11:53:12 UTC
Created attachment 200983 [details]
licq-qt-gui.diff

I've also send this as a message on ports-committers, but I am filing
this PR so that it is not lost.

Message was about the switch to Qt 5 in ports r489554:

"Is adding qt5-buildtools (moc and rcc) as a run dependency intentional,
or should this have USE_QT=buildtools_build instead, similar to the
Qt 4 version with USE_QT=moc_build rcc_build?"

I do not see any evidence that qt5-buildtools is needed at runtime,
so I am attaching a patch that removes it.

It also fixes the following QA warning:

/!\ licq-qt-gui-1.9.0: Makefile warnings, please consider fixing /!\

You are using USE_GITHUB and WRKSRC is set which is wrong.  Set GH_PROJECT
correctly, set WRKSRC_SUBDIR or remove WRKSRC entirely.
Comment 1 commit-hook freebsd_committer 2019-01-19 07:21:16 UTC
A commit references this bug:

Author: dinoex
Date: Sat Jan 19 07:21:04 UTC 2019
New revision: 490709
URL: https://svnweb.freebsd.org/changeset/ports/490709

Log:
  - reduce runtime dependencies
  PR:		234819
  Submitted by:	tobik

Changes:
  head/net-im/licq-qt-gui/Makefile
Comment 2 Tobias Kortkamp freebsd_committer 2019-01-19 14:25:06 UTC
Thank you.