Bug 234862 - multimedia/transcode: fails to link on i386 with lld as system linker
Summary: multimedia/transcode: fails to link on i386 with lld as system linker
Status: Closed DUPLICATE of bug 234818
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ed Maste
URL:
Keywords:
Depends on:
Blocks: 214864
  Show dependency treegraph
 
Reported: 2019-01-11 14:08 UTC by Ed Maste
Modified: 2019-01-14 05:29 UTC (History)
1 user (show)

See Also:
cyberbotx: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2019-01-11 14:08:51 UTC
http://package18.nyi.freebsd.org/build.html?mastername=headi386PR214864-default&build=2019-01-05_21h00m02s
http://package18.nyi.freebsd.org/data/headi386PR214864-default/2019-01-05_21h00m02s/logs/errors/transcode-1.1.7_37.log

ld: error: can't create dynamic relocation R_386_32 against local symbol in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
>>> defined in ../../aclib/.libs/libac.a(memcpy.o)
>>> referenced by memcpy.c
>>>               memcpy.o:(memcpy_mmx) in archive ../../aclib/.libs/libac.a

ld: error: can't create dynamic relocation R_386_32 against local symbol in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
>>> defined in ../../aclib/.libs/libac.a(memcpy.o)
>>> referenced by memcpy.c
>>>               memcpy.o:(memcpy_mmx) in archive ../../aclib/.libs/libac.a

ld: error: can't create dynamic relocation R_386_32 against local symbol in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
>>> defined in ../../aclib/.libs/libac.a(memcpy.o)
>>> referenced by memcpy.c
>>>               memcpy.o:(memcpy_mmx) in archive ../../aclib/.libs/libac.a
...
Comment 1 Naram Qashat 2019-01-14 04:17:37 UTC
Duplicate of bug #234818 (that one has a fix in it).
Comment 2 Ed Maste freebsd_committer 2019-01-14 05:02:41 UTC

*** This bug has been marked as a duplicate of bug 234818 ***