Bug 234865 - math/py-z3-solver: fails to build on i386 with lld as system linker
Summary: math/py-z3-solver: fails to build on i386 with lld as system linker
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks: 214864
  Show dependency treegraph
 
Reported: 2019-01-11 14:13 UTC by Ed Maste
Modified: 2020-06-10 17:08 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2019-01-11 14:13:56 UTC
http://package18.nyi.freebsd.org/build.html?mastername=headi386PR214864-default&build=2019-01-05_21h00m02s
http://package18.nyi.freebsd.org/data/headi386PR214864-default/2019-01-05_21h00m02s/logs/errors/py36-z3-solver-4.7.1.log

ld: error: can't create dynamic relocation R_386_32 against symbol: .L.str in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
>>> defined in api/dll/gparams_register_modules.o
>>> referenced by gparams_register_modules.cpp
>>>               api/dll/gparams_register_modules.o:(gparams_register_modules())

ld: error: can't create dynamic relocation R_386_32 against symbol: .L.str.37 in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
>>> defined in api/dll/gparams_register_modules.o
>>> referenced by gparams_register_modules.cpp
>>>               api/dll/gparams_register_modules.o:(gparams_register_modules())
...
Comment 1 Ed Maste freebsd_committer 2019-07-24 19:35:29 UTC
lld has been enabled as system linker for i386 on stable/12 in advance of 12.1 (base svn r350297, a few minutes ago)
Comment 2 Ed Maste freebsd_committer 2020-06-10 13:58:13 UTC
This currently fails to build for me for unrelated C++ reasons.
Comment 3 Yuri Victorovich freebsd_committer 2020-06-10 16:00:29 UTC
(In reply to Ed Maste from comment #2)

Ed,

I can't reproduce any of the problems on 12.1, It builds successfully in poudriere.
Comment 4 Ed Maste freebsd_committer 2020-06-10 17:08:51 UTC
(In reply to Yuri Victorovich from comment #3)
Thanks for the follow-up, this is perhaps an issue that will come with Clang 10. But in any case the lld i386 build failure is no longer, so I'll close this.