Bug 234876 - [PATCH]: x11/nvidia-driver: Don't use NVidia-provided libGL.so/libEGL.so/libGLESv2.so
Summary: [PATCH]: x11/nvidia-driver: Don't use NVidia-provided libGL.so/libEGL.so/libG...
Status: Closed DUPLICATE of bug 226403
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-11 15:44 UTC by Neel Chauhan
Modified: 2019-01-18 17:54 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
Patch (Revision 1) (1.37 KB, patch)
2019-01-11 15:44 UTC, Neel Chauhan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2019-01-11 15:44:47 UTC
Created attachment 201032 [details]
Patch (Revision 1)

If I use GNOME and GDM on a computer with a NVidia GT 1030, and use the nvidia-driver from pkg, I get errors like this:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

GDM is also on a blank screen.

My setup is:

 * HP Slimline 290-p0014
 * Intel Core i7-8700
 * 24GB DDR4 (8GB HP OEM, 16GB G.Skill)
 * 512GB NVMe (Patriot SSD)
 * NVidia GT 1030 (2GB, Zotac card)
 * FreeBSD 12.0

My patch is attached and is tested to work with GDM and GNOME. It was originally from Bug 226403 but rebased on the current Ports tree.
Comment 1 Tijl Coosemans freebsd_committer 2019-01-18 17:54:07 UTC

*** This bug has been marked as a duplicate of bug 226403 ***