Bug 234891 - multimedia/libva-intel-driver: unbreak Wayland with Mesa 18.3
Summary: multimedia/libva-intel-driver: unbreak Wayland with Mesa 18.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords: patch
Depends on:
Blocks: 233034
  Show dependency treegraph
 
Reported: 2019-01-12 10:01 UTC by Jan Beich
Modified: 2019-01-16 19:56 UTC (History)
1 user (show)

See Also:
madpilot: maintainer-feedback+


Attachments
v1 (2.60 KB, patch)
2019-01-12 10:01 UTC, Jan Beich
jbeich: maintainer-approval? (madpilot)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-01-12 10:01:13 UTC
Created attachment 201055 [details]
v1

$ mpv --hwdec=vaapi /path/to/foo.mp4
...
error: failed to resolve wl_drm_interface(): Undefined symbol "wl_drm_interface"
[vaapi] libva: /usr/local/lib/dri/i965_drv_video.so init failed
....

$ nm /usr/local/lib/libva-wayland.so | fgrep wl_drm_interface
00000000000051f0 d wl_drm_interface
Comment 1 Guido Falsi freebsd_committer 2019-01-14 14:09:17 UTC
The patch did not apply cleanly, There's a misalignment in the PORTREVISION line.

Anyway After cleaning it it's ok.

BTW, would you like to take maintainership for libva and libva-intel-driver? You look better informed than me on the subject and so better suited as the maintainer.

If you accept I'd commit this bug and bug 234925 including the maintainer change to you freebsd address.
Comment 2 Jan Beich freebsd_committer 2019-01-16 12:57:52 UTC
I accept maintainership but can't promise to work with upstream (due to lack of time/skills).

If you plan to land the patch yourself, please
- Change "mesa-libs >= 18.3.0" comment to "mesa-libs 18.3+" (in both ports)
  for consistency with another PATCHFILES line.
- Add BUILD_DEPENDS=libva>=2.3.0_3:multimedia/libva to libva-intel-media-driver

(In reply to Guido Falsi from comment #1)
> The patch did not apply cleanly, There's a misalignment
> in the PORTREVISION line.

I can't reproduce with the current ports tree.
Comment 3 commit-hook freebsd_committer 2019-01-16 18:04:46 UTC
A commit references this bug:

Author: madpilot
Date: Wed Jan 16 18:04:06 UTC 2019
New revision: 490498
URL: https://svnweb.freebsd.org/changeset/ports/490498

Log:
  - Unbreak Wayland support in libva-intel-driver with Mesa 18.3 [1]
  - Allow disabling X11 support in libva [2]
  - Update minimum version requirement in libva-intel-media-driver
    BUILD_DEPENDS (required by submitter/maintainer) [1]
  - While here, silence some portling warnings
  - Pass maintainership to jbeich (submitter) [1]

  PR:		234891 [1], 234925 [2]
  Submitted by:	jbeich

Changes:
  head/multimedia/libva/Makefile
  head/multimedia/libva/distinfo
  head/multimedia/libva/pkg-plist
  head/multimedia/libva-intel-driver/Makefile
  head/multimedia/libva-intel-driver/distinfo
  head/multimedia/libva-intel-media-driver/Makefile
Comment 4 Guido Falsi freebsd_committer 2019-01-16 18:06:55 UTC
Committed.

I did not have much collaboration with upstream actually, apart from build related fixes.

You really seem to know the subject better than me!

Thanks!
Comment 5 Jan Beich freebsd_committer 2019-01-16 19:32:42 UTC
(In reply to commit-hook from comment #3)
>  - Update minimum version requirement in libva-intel-media-driver
>    BUILD_DEPENDS (required by submitter/maintainer) [1]

Actually, I've typo'd libva-intel-driver as libva-intel-media-driver. ;)
Comment 6 Guido Falsi freebsd_committer 2019-01-16 19:56:31 UTC
(In reply to Jan Beich from comment #5)
> (In reply to commit-hook from comment #3)
> >  - Update minimum version requirement in libva-intel-media-driver
> >    BUILD_DEPENDS (required by submitter/maintainer) [1]
> 
> Actually, I've typo'd libva-intel-driver as libva-intel-media-driver. ;)

It did look strange, but you being the maintainer, I thought you knew better.

Anyway all tree ports will be rebuilt, so it should be ok as is.