Bug 234921 - mail/spamassassin: missing dependency on net/p5-Net-CIDR-Lite
Summary: mail/spamassassin: missing dependency on net/p5-Net-CIDR-Lite
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-13 14:22 UTC by Larry Rosenman
Modified: 2019-02-05 18:19 UTC (History)
3 users (show)

See Also:
zeising: maintainer-feedback+


Attachments
patch to add p5-Net-CIDR-Lite (731 bytes, patch)
2019-01-13 14:22 UTC, Larry Rosenman
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Rosenman freebsd_committer 2019-01-13 14:22:03 UTC
Created attachment 201099 [details]
patch to add p5-Net-CIDR-Lite

I rebuilt and cleaned my ports yesterday and got the following:

⌂63% [root@thebighonker.lerctr.org:~] # /usr/local/bin/spamd
Jan 13 07:47:03.624 [82727] error: Can't locate Net/CIDR/Lite.pm in @INC (you may need to install the Net::CIDR::Lite module) (@INC contains: lib /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/site_perl/mach/5.28 /usr/local/lib/perl5/5.28/mach /usr/local/lib/perl5/5.28) at /usr/local/lib/perl5/site_perl/Mail/SpamAssassin/Plugin/URILocalBL.pm line 106.

I use the following options:
⌂78% [ler@borg.lerctr.org:~/FreeBSD/ports/mail/spamassassin] ports(1) 1 ‡ sudo poudriere options -c -n -j p120-S-amd64 -s mail/spamassassin
[00:00:00] Appending to make.conf: /usr/local/etc/poudriere.d/p120-S-amd64-make.conf
===> The following configuration options are available for spamassassin-3.4.2_2:
     AS_ROOT=on: Run spamd as root (recommended)
     DOCS=on: Build and/or install documentation
     SSL=on: SSL protocol support
====> Optional user-config/bayes database backends
     MYSQL=off: MySQL database support
     PGSQL=on: PostgreSQL database support
====> Optional SpamAssassin plugins
     DCC=off: DCC digest list support (mail/dcc-dccd)
     DKIM=on: Verify DKIM records (mail/p5-Mail-DKIM)
     PYZOR=off: Pyzor digest list support (mail/pyzor)
     RAZOR=on: Vipul's Razor digest list support (mail/razor-agents)
     RELAY_COUNTRY=on: Location-based scoring (net/p5-GeoIP2)
     RLIMIT=off: Resource limits (devel/p5-BSD-Resource)
     SPF_QUERY=on: Verify SPF records (mail/p5-Mail-SPF)
====> GnuPG (for sa-update): you have to select exactly one of them
     GNUPG_NONE=off: Do not use GnuPG
     GNUPG=off: GnuPG 1 (security/gnupg1)
     GNUPG2=on: GnuPG 2 (security/gnupg)
===> Use 'make config' to modify these settings
⌂80% [ler@borg.lerctr.org:~/FreeBSD/ports/mail/spamassassin] ports(1) ‡

I'm not sure what option requires it (RELAY_COUNTRY?) so I put an unconditional patch (attached)
Comment 1 Larry Rosenman freebsd_committer 2019-02-05 15:20:59 UTC
Any objections to my committing this?

@zeising
Comment 2 Niclas Zeising freebsd_committer 2019-02-05 18:12:08 UTC
I haven't looked at the details, but I have no objection.
Comment 3 commit-hook freebsd_committer 2019-02-05 18:15:56 UTC
A commit references this bug:

Author: ler
Date: Tue Feb  5 18:15:43 UTC 2019
New revision: 492264
URL: https://svnweb.freebsd.org/changeset/ports/492264

Log:
  mail/spamassassin: missing dependency on net/p5-Net-CIDR-Lite

  PR:		234921
  Submitted by:	ler@FreeBSD.org
  Approved by:	zeising

Changes:
  head/mail/spamassassin/Makefile
Comment 4 Larry Rosenman freebsd_committer 2019-02-05 18:16:32 UTC
Committed.  Thanks, Niclas.