Bug 234928 - x11-toolkits/fltk-devel: fix build with GCC-based architectures
Summary: x11-toolkits/fltk-devel: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mark Linimon
URL:
Keywords:
: 233698 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-13 23:02 UTC by Piotr Kubaj
Modified: 2019-02-14 03:55 UTC (History)
1 user (show)

See Also:


Attachments
patch (680 bytes, patch)
2019-01-13 23:02 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-01-13 23:02:47 UTC
Created attachment 201106 [details]
patch

Base GCC doesn't support -Wno-c++11-narrowing. Replace it with USE_CXXSTD=c++98.

Also add USES=gl localbase:ldflags.

Tested on powerpc64 and amd64.

Hardware sponsored by IntegriCloud.
Comment 1 commit-hook freebsd_committer 2019-01-16 05:05:13 UTC
A commit references this bug:

Author: linimon
Date: Wed Jan 16 05:04:54 UTC 2019
New revision: 490446
URL: https://svnweb.freebsd.org/changeset/ports/490446

Log:
  Base GCC doesn't support -Wno-c++11-narrowing.  Replace it with
  USE_CXXSTD=c++98.

  While here, add now-recommended USES=gl, and tidy up by using
  localbase:ldflags.

  PR:		234928
  Submitted by:	Piotr Kubaj

Changes:
  head/x11-toolkits/fltk-devel/Makefile
Comment 2 Koichiro Iwao freebsd_committer 2019-02-14 03:55:23 UTC
*** Bug 233698 has been marked as a duplicate of this bug. ***