Bug 235038 - x11/nvidia-driver: FreeBSD 12.0 Nvidia Driver not working
Summary: x11/nvidia-driver: FreeBSD 12.0 Nvidia Driver not working
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-18 03:02 UTC by SF
Modified: 2019-09-02 12:39 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SF 2019-01-18 03:02:11 UTC
3d is partially working, i did try the patch from ports(Bug 228287)(https://svnweb.freebsd.org/ports?view=revision&revision=487446). This works identically to current pkg implementations of 390.87. Newest version of pkg nvidia driver doesn't work in any way. With 390.87_1 nothing is working.

With the old driver 390.87 i am getting this with some programs, others are working:

00bd:fixme:ntdll:EtwRegisterTraceGuidsA (0x7721212f, 0x7724bfc0, {0cfe0455-93ba-440d-a3fe-553973d0b723}, 1, 0x2a6ea90, (null), (null), 0x7724bfc8): stub
00bd:fixme:ntdll:EtwRegisterTraceGuidsA (0x7721212f, 0x7724bfe0, {797fabac-7b58-4796-b924-d51178a59ce4}, 1, 0x2a6ea90, (null), (null), 0x7724bfe8): stub
00bd:fixme:ntdll:EtwEventRegister ({43d1a55c-76d6-4f7e-995c-64c711e5cafe}, 
0x7723dc30, 0x0, 0x7724b738) stub.

>>>00bd:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0x1.<<<

00bd:fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
00bd:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
$ 00cf:fixme:process:ProcessIdToSessionId Unsupported for other processes.
00cf:fixme:ver:GetCurrentPackageId (0x33fea4 0x0): stub
Comment 1 SF 2019-01-18 03:16:05 UTC
390.87_1:

009b:fixme:ntdll:EtwRegisterTraceGuidsA (0x7721212f, 0x7724bfc0, {0cfe0455-93ba-440d-a3fe-553973d0b723}, 1, 0x2a6ea90, (null), (null), 0x7724bfc8): stub
009b:fixme:ntdll:EtwRegisterTraceGuidsA (0x7721212f, 0x7724bfe0, {797fabac-7b58-4796-b924-d51178a59ce4}, 1, 0x2a6ea90, (null), (null), 0x7724bfe8): stub
009b:fixme:ntdll:EtwEventRegister ({43d1a55c-76d6-4f7e-995c-64c711e5cafe}, 0x7723dc30, 0x0, 0x7724b738) stub.

>>>009b:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0x1.<<<

009b:fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
00ad:fixme:process:ProcessIdToSessionId Unsupported for other processes.
00ad:fixme:ver:GetCurrentPackageId (0x33fea4 0x0): stub
009b:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
Comment 2 SF 2019-01-18 03:20:17 UTC
Disabling csmt doesn't make any difference.
Comment 3 Alex S 2019-01-18 04:10:28 UTC
This should marked as a duplicate of bug 231812, which is a bogus report itself because patch-nvidia.sh script is included in i386-wine port.
Comment 4 SF 2019-01-18 06:10:24 UTC
You wouldn't get

>>>00bd:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0x1.<<<

if patch-nvidia.sh is the problem.

They did say something about linux compatibility libraries but this got (partially?) fixed?

Bug 228287 doesn't mention this and Bug 231812 was closed as duplicate of it but definitely isn't.
Comment 5 Alex S 2019-01-18 06:36:22 UTC
(In reply to SF from comment #4)

Wine does not utilize Linuxulator. It does, however, require downloading native FreeBSD 32-bit OpenGL libs, as those are not included in nvidia-driver package.

Personally, I consider all of your activity (here and on forums.freebsd.org under nickname Yelphos) trolling. I'm only replying because this report has been cross-referenced with the issue I'm subscribed to, which is incredibly annoying.
Comment 6 SF 2019-01-18 08:04:55 UTC
Seems like this guy is ai-controlled, ignore him. Maybe this ai knows my real identity, there is some people hostile to me.

The thing i did describe is something which follows onto Bug 228287, is is a new kind of bug.
Comment 7 Walter Schwarzenfeld freebsd_triage 2019-09-02 12:39:19 UTC
Any news here resp. is this still relevant?