Bug 235114 - [new port]: x11/rofi-pass - Rofi frontend for pass
Summary: [new port]: x11/rofi-pass - Rofi frontend for pass
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
: 235118 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-21 17:43 UTC by Alexander Sieg
Modified: 2019-02-27 04:07 UTC (History)
0 users

See Also:


Attachments
shar of new port (2.11 KB, text/plain)
2019-01-21 21:30 UTC, Alexander Sieg
no flags Details
new port version 2.0.2 (4.48 KB, text/plain)
2019-02-14 13:09 UTC, Alexander Sieg
no flags Details
added missing run dependencies (316 bytes, text/plain)
2019-02-26 17:30 UTC, Alexander Sieg
no flags Details
fixed shar file not having any content (4.50 KB, text/plain)
2019-02-26 19:10 UTC, Alexander Sieg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Sieg 2019-01-21 17:43:52 UTC
A bash script to handle Simple Password Store in a convenient way using rofi.

WWW: https://github.com/carnager/rofi-pass

--
Generated by ports-mgmt/freebsd-bugzilla-cli - v0.15.0.
Comment 1 Tobias Kortkamp freebsd_committer 2019-01-21 18:32:05 UTC
(In reply to alex from comment #0)
> A bash script to handle Simple Password Store in a convenient way using rofi.
> 
> WWW: https://github.com/carnager/rofi-pass
> 
> --
> Generated by ports-mgmt/freebsd-bugzilla-cli - v0.15.0.

There is no patch attached here.  I'd suggest not using freebsd-bugzilla-cli
for this and just uploading it manually.
Comment 2 Tobias Kortkamp freebsd_committer 2019-01-21 21:12:37 UTC
*** Bug 235118 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Sieg 2019-01-21 21:30:16 UTC
Created attachment 201317 [details]
shar of new port
Comment 4 Alexander Sieg 2019-02-14 13:09:05 UTC
Created attachment 202014 [details]
new port version 2.0.2
Comment 5 Alexander Sieg 2019-02-14 13:10:06 UTC
reopening. because closing was by mistake
Comment 6 Alexander Sieg 2019-02-26 17:30:47 UTC
Created attachment 202388 [details]
added missing run dependencies
Comment 7 Alexander Sieg 2019-02-26 19:10:21 UTC
Created attachment 202390 [details]
fixed shar file not having any content
Comment 8 Tobias Kortkamp freebsd_committer 2019-02-27 04:07:29 UTC
Committed with changes. Thanks!
Comment 9 commit-hook freebsd_committer 2019-02-27 04:07:53 UTC
A commit references this bug:

Author: tobik
Date: Wed Feb 27 04:07:12 UTC 2019
New revision: 494017
URL: https://svnweb.freebsd.org/changeset/ports/494017

Log:
  New port: x11/rofi-pass

  A bash script to handle Simple Password Store in a convenient way
  using rofi.

  Features:
  - Open URLs of entries with hotkey
  - Add new Entries to Password Storage
  - Edit existing Entries
  - Generate new passwords for entries
  - Inline view, which can copy/type individual entries
  - Move/Delete existing entries
  - Type any field from entry
  - Auto-typing of user and/or password fields
  - Generating OTPs

  WWW: https://github.com/carnager/rofi-pass

  PR:		235114
  Submitted by:	alex@xanderio.de

Changes:
  head/x11/Makefile
  head/x11/rofi-pass/
  head/x11/rofi-pass/Makefile
  head/x11/rofi-pass/distinfo
  head/x11/rofi-pass/pkg-descr