Bug 235164 - multimedia/vlc: opus in mkv container is not properly demultiplexed
Summary: multimedia/vlc: opus in mkv container is not properly demultiplexed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-23 21:17 UTC by Dwayne MacKinnon
Modified: 2021-03-07 10:14 UTC (History)
7 users (show)

See Also:
riggs: maintainer-feedback+


Attachments
VLC knows it didn't played audio from statistics info. (238.68 KB, image/png)
2019-02-03 19:38 UTC, Eric Camachat
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dwayne MacKinnon 2019-01-23 21:17:01 UTC
Running vlc-3.0.6_1,4 on FreeBSD 12.0-RELEASE 64-bit.

I'm not sure when this problem crept into vlc; I use it fairly often but I only have 2 or three .mkv files.

When I run vlc on the command line and pass it a .mkv file I get the following output:

[0000000800905060] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00000008126be160] mkv demux error: cannot find KaxSegment or missing mandatory KaxInfo
[0000000814246060] egl_x11 gl error: cannot select OpenGL API
[00000008127c2760] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  390.87  Tue Aug 21 15:52:44 PDT 2018 for hardware decoding
[00000008127c2ae0] main decoder error: buffer deadlock prevented

The .mkv file audio is fine when using dragon or gst-play-1.0. According to mkvinfo (multimedia/mkvtoolnix) the audio is using the OPUS codec.
Comment 1 Eric Camachat 2019-01-28 06:32:24 UTC
I have this problem too.

Try transcode OPUS to MP4 works for me. So that's must be something related to VLC's OPUS module.
Comment 2 Anton 2019-01-29 18:10:11 UTC
I seem to have the same bug with .webm file and on Gentoo Linux -- but with OPUS codec. (It's VLC 3.0.4)
Comment 3 Thomas Zander freebsd_committer 2019-02-03 16:42:25 UTC
(In reply to Eric Camachat from comment #1)

Does playing a pure opus audio file work?
Comment 4 Eric Camachat 2019-02-03 18:52:58 UTC
(In reply to Thomas Zander from comment #3)
Plays opus audio only works fine.
File format are the same (mkv), but with video track it will be no sound output.

I also tested VLC on MacOS same problem exists, too.
Comment 5 Eric Camachat 2019-02-03 19:30:45 UTC
(In reply to Thomas Zander from comment #3)
Correction: VLC on MacOS works fine.
Comment 6 Eric Camachat 2019-02-03 19:38:24 UTC
Created attachment 201691 [details]
VLC knows it didn't played audio from statistics info.

VLC knows it decoded opus but didn't play it.
Comment 7 Alex Wied 2019-05-13 01:01:04 UTC
I too am experiencing this problem. Playback with Opus in OGG works properly.
Comment 8 Thomas Zander freebsd_committer 2019-06-20 16:39:26 UTC
I was hoping 3.0.7 contains a fix, but it seems still affected.
Comment 9 daniel.engberg.lists 2020-12-12 00:43:46 UTC
Still an issue?
Comment 10 Eric Camachat 2020-12-12 00:54:18 UTC
(In reply to daniel.engberg.lists from comment #9)
Yes, this is still an issue.
Comment 11 Thomas Zander freebsd_committer 2020-12-12 12:24:33 UTC
I started digging a few months ago but didn't find the root of the problem. It's still on my todo list but if anyone has time, I'd appreciate the help.
Comment 12 Eric Camachat 2021-02-24 07:24:47 UTC
The problem is gone after upgrade to v3.0.12.
Comment 13 daniel.engberg.lists 2021-03-03 07:47:38 UTC
Great, thanks for following up on this!
Comment 14 Chris Rees freebsd_committer 2021-03-03 11:44:03 UTC
Submitter reports fixed in latest version
Comment 15 cayen14422 2021-03-04 16:17:11 UTC
MARKED AS SPAM
Comment 16 Thomas Zander freebsd_committer 2021-03-07 10:14:41 UTC
Apparently, in this case we could wait it out, but still dissatisfying not to know what the reason was :-(