Bug 235171 - devel/qca: Undefined symbol "EVP_MD_CTX_new"
Summary: devel/qca: Undefined symbol "EVP_MD_CTX_new"
Status: Closed DUPLICATE of bug 232784
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords: needs-patch
Depends on:
Blocks: 231931
  Show dependency treegraph
 
Reported: 2019-01-24 05:12 UTC by Damjan Jovanovic
Modified: 2019-02-23 21:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damjan Jovanovic 2019-01-24 05:12:00 UTC
# pkg install kdeconnect-kde
# /usr/local/lib/libexec/kdeconnectd
kdeconnect.core: KdeConnect daemon starting
/usr/local/lib/qca-qt5/crypto/libqca-ossl.so: Undefined symbol "EVP_MD_CTX_new"

# pkg which /usr/local/lib/qca-qt5/crypto/libqca-ossl.so
/usr/local/lib/qca-qt5/crypto/libqca-ossl.so was installed by package qca-qt5-2.1.3_4


Workaround:
# pkg install openssl111
# LD_PRELOAD=/usr/local/lib/libssl.so /usr/local/lib/libexec/kdeconnectd
(still crashes, but for a different reason)
Comment 1 Raphael Kubo da Costa freebsd_committer 2019-02-23 12:53:32 UTC
Damjan, what FreeBSD are you running? It looks like the package was built against OpenSSL 1.1.1 but the OpenSSL libqca-oss.so is loading in your machine is older.
Comment 2 Damjan Jovanovic 2019-02-23 13:35:12 UTC
(In reply to Raphael Kubo da Costa from comment #1)

FreeBSD ----- 11.2-RELEASE FreeBSD 11.2-RELEASE #0 r335510: Fri Jun 22 04:32:14 UTC 2018     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 3 Raphael Kubo da Costa freebsd_committer 2019-02-23 17:33:34 UTC
Right, and are you using the official package for qca, and is the problem still there?
Comment 4 Raphael Kubo da Costa freebsd_committer 2019-02-23 21:01:13 UTC

*** This bug has been marked as a duplicate of bug 232784 ***