Bug 235174 - databases/grass7: fail to update/install: r.watershed/seg failed: No such file or directory
Summary: databases/grass7: fail to update/install: r.watershed/seg failed: No such fil...
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-24 08:43 UTC by O. Hartmann
Modified: 2019-07-16 15:27 UTC (History)
3 users (show)

See Also:
lbartoletti: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2019-01-24 08:43:50 UTC
Updating a grass7 installation on one of our boxes, I run permanently into this weird error while in last stage of updating/installation:

[...]

/usr/bin/strip /usr/ports/databases/grass7/work/stage/usr/local/grass-7.4.4/etc/r.watershed/seg
strip: open /usr/ports/databases/grass7/work/stage/usr/local/grass-7.4.4/etc/r.watershed/seg failed: No such file or directory
Comment 1 Loïc Bartoletti 2019-01-30 19:06:08 UTC
Hi,

I couldn't reproduce the problem.
What is your options? 
Can you try with grass 7.6.0  #235307 ?

Thanks.
Comment 2 Loïc Bartoletti 2019-03-14 06:27:07 UTC
Hi,

Can you rebuild the port but with a "make clean build stage" command ?

I thought I saw a similar problem when I prepared the update to the new version of GRASS and it disappeared with a make clean and a rebuild.

In poudriere, I never have this problem.
Comment 3 Li-Wen Hsu freebsd_committer 2019-07-16 15:27:26 UTC
Feedback timeout, but there is another open issue at bug238846.