Bug 235201 - editors/emacs Hunspell (1.7.0) breaks ispell.el
Summary: editors/emacs Hunspell (1.7.0) breaks ispell.el
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: emacs@FreeBSD.org (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-25 19:22 UTC by abij
Modified: 2019-01-31 19:37 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (emacs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abij 2019-01-25 19:22:17 UTC
Overview: 
Hunspell (1.7.0) breaks ispell.el. It was already reported upstream and claimed fixed. But freebsd still ships unfixed /lisp/textmodes/ispell.el

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=33493

Emacs version: emacs-26.1_4,3
GNU Emacs 26.1 (build 1, amd64-portbld-freebsd12.0, GTK+ Version 3.22.30)

Steps to Reproduce:
Enable spell check using flyspell, then error pops up. It was working before upgrading to hunspell 1.7.

Flyspell mode disabled in current buffer
Flyspell mode enabled in current buffer
Error in post-command-hook (flyspell-post-command-hook): (error "No data for dictionary \"en_US\" in ‘ispell-local-dictionary-alist’ or ‘ispell-dictionary-alist’")
Comment 1 Joseph Mingrone freebsd_committer 2019-01-25 19:30:58 UTC
We still ship it, because Emacs 26.1 is the latest upstream release. If I can find a bit of time, I will include that patch in the current port.

The pretest for what will be the 26.2 port is available if you want to test. https://reviews.freebsd.org/D18810
Comment 2 commit-hook freebsd_committer 2019-01-31 19:35:11 UTC
A commit references this bug:

Author: jrm
Date: Thu Jan 31 19:34:23 UTC 2019
New revision: 491755
URL: https://svnweb.freebsd.org/changeset/ports/491755

Log:
  editors/emacs: Fix spellchecking with hunspell 1.7.0

  While here, silence warning about USE_GNOME without USES=gnome.

  PR:		235201
  Reported by:	abij@tuta.io

Changes:
  head/editors/emacs/Makefile
  head/editors/emacs/files/patch-lisp_textmodes_ispell.el
Comment 3 Joseph Mingrone freebsd_committer 2019-01-31 19:37:01 UTC
Thanks for reporting. Please let us know if there are still problems.