Bug 235205 - deskutils/recoll: update to 1.24.3
Summary: deskutils/recoll: update to 1.24.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-25 21:26 UTC by jjuanino
Modified: 2019-01-25 23:08 UTC (History)
1 user (show)

See Also:


Attachments
update to 1.24.3 (9.25 KB, patch)
2019-01-25 21:26 UTC, jjuanino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jjuanino 2019-01-25 21:26:33 UTC
Created attachment 201402 [details]
update to 1.24.3

Hi, I send a patch to update recoll to 1.24.3 version:

* New dependency of QT5. Remove all references to QT4
* Add gnome to USES
* Shebang file desktop/hotrecoll.py moved to filters/hotrecoll.py
* Portlint suggestions:
    USE_LDCONFIG=yes
    USE_GL+=gl when QT5 options is enabled


Changelog:

https://www.lesbonscomptes.com/recoll/release-1.24.html
Comment 1 Yuri Victorovich freebsd_committer 2019-01-25 23:08:29 UTC
Committed with a small addition.

Thank you for your submission!
Yuri
Comment 2 commit-hook freebsd_committer 2019-01-25 23:08:52 UTC
A commit references this bug:

Author: yuri
Date: Fri Jan 25 23:08:24 UTC 2019
New revision: 491209
URL: https://svnweb.freebsd.org/changeset/ports/491209

Log:
  deskutils/recoll: Update 1.23.7 -> 1.24.3

  * New dependency of QT5. Remove all references to QT4
  * Add gnome to USES
  * Shebang file desktop/hotrecoll.py moved to filters/hotrecoll.py
  * Portlint suggestions:
      USE_LDCONFIG=yes
      USE_GL+=gl when QT5 options is enabled

  Changelog:
  https://www.lesbonscomptes.com/recoll/release-1.24.html

  PR:		235205
  Submitted by:	jjuanino@gmail.com

Changes:
  head/deskutils/recoll/Makefile
  head/deskutils/recoll/distinfo
  head/deskutils/recoll/pkg-plist