Bug 235214 - www/firefox One-inch gap display from top of screen in x11-wm/i3
Summary: www/firefox One-inch gap display from top of screen in x11-wm/i3
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Baptiste Daroussin
Depends on:
Reported: 2019-01-26 12:04 UTC by Rob Belics
Modified: 2020-03-24 12:14 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bapt)


Note You need to log in before you can comment on or make changes to this bug.
Description Rob Belics 2019-01-26 12:04:20 UTC
I'm not sure if this is a Firefox issue, an i3 issue or something I did. In i3, I open Firefox and it displays briefly in a new, tiled window, then a one-inch gap appears at the top. All of the links that would normally be positioned in that one-inch gap work but they are off by one inch. iow, a link to a home button will work if you can find it in this gap area but the actual text for "home" is one inch lower and the home button will change color to indicate it's being hovered over.

The only possibility that I caused the issue is I tried to experiment with x11-wm/sway and couldn't get that to work. I reinstalled firefox, made sure no wayland options were around, but the only application with this issue is firefox.

When I make the tile floated, firefox behaves normally. There are no errors in the console that could pertain to this.

And now I tried to take a screenshot but the problem went away. This happened before and I'm sure it will come back.
Comment 1 Marcin Cieślak 2020-03-24 12:01:30 UTC
I have no issues running firefox 74.0_5,1 on FreeBSD 11.3 stable using x11-wm/dwm and I do not need to float the browser, it gets tiled easily.

Can you try dwm maybe and see?
Comment 2 Rob Belics 2020-03-24 12:14:43 UTC
Since there isn't anyone who has reported this issue, and I have since replaced the workstation and don't even remember reporting this, I am closing it as "Unable to Reproduce".