Bug 235273 - lang/perl5.28 compile failed
Summary: lang/perl5.28 compile failed
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-28 06:18 UTC by ykla
Modified: 2019-05-28 05:09 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ykla 2019-01-28 06:18:08 UTC
--- dist/Storable/lib/Storable/Limit.pm ---
Storable: determining recursion limit: 64998 passed, try more 64999 ...
Storable: determining recursion limit: 64999 passed, try more 64999 ...
MAX_DEPTH_HASH = 64999
--- lib/Storable/Limit.pm ---
test -d lib/Storable || mkdir lib/Storable
cp dist/Storable/lib/Storable/Limit.pm lib/Storable/Limit.pm
--- lib/auto/XS/APItest/APItest.so ---
--- pm_to_blib ---
--- ../../lib/auto/XS/APItest/APItest.bs ---
/usr/ports/lang/perl5.28/work/perl-5.28.1/ext/XS-APItest/../../miniperl "-I../../lib" -MExtUtils::Command::MM -e 'cp_nonempty' -- APItest.bs ../../lib/auto/XS/APItest/APItest.bs 644
--- lib/auto/re/re.so ---
--- re_comp.o ---
--- re.o ---
--- re_comp.o ---
cc -c    -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2 -Wall -Werror=declaration-after-statement -Werror=pointer-arith -Wextra -Wc++-compat -Wwrite-strings -O2 -pipe -fno-strict-aliasing    -DVERSION=\"0.36\"  -DXS_VERSION=\"0.36\" -DPIC -fPIC "-I../.."  -DPERL_EXT_RE_BUILD -DPERL_EXT_RE_DEBUG -DPERL_EXT re_comp.c
--- re.o ---
cc -c    -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2 -Wall -Werror=declaration-after-statement -Werror=pointer-arith -Wextra -Wc++-compat -Wwrite-strings -O2 -pipe -fno-strict-aliasing    -DVERSION=\"0.36\"  -DXS_VERSION=\"0.36\" -DPIC -fPIC "-I../.."  -DPERL_EXT_RE_BUILD -DPERL_EXT_RE_DEBUG -DPERL_EXT re.c
--- lib/auto/XS/APItest/APItest.so ---
--- notcore.o ---
Segmentation fault (core dumped)
*** [notcore.o] Error code 139

make[11]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1/ext/XS-APItest
1 error

make[11]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1/ext/XS-APItest
A failure has been detected in another branch of the parallel make

make[11]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1/ext/XS-APItest
Unsuccessful make(ext/XS-APItest): code=512 at make_ext.pl line 570.
*** [lib/auto/XS/APItest/APItest.so] Error code 25

make[10]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1
--- lib/auto/re/re.so ---
--- re_comp.o ---
re_comp.c:16202:36: warning: performing pointer arithmetic on a null pointer has undefined behavior [-Wnull-pointer-arithmetic]
                                && ckDEAD(packWARN(WARN_REGEXP));
                                   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:231:6: note: expanded from macro 'ckDEAD'
    !specialWARN(PL_curcop->cop_warnings) &&                            \
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:24:53: note: expanded from macro 'specialWARN'
#define specialWARN(x)          ((x) == pWARN_STD || (x) == pWARN_ALL ||        \
                                                            ^~~~~~~~~
../../warnings.h:21:33: note: expanded from macro 'pWARN_ALL'
#define pWARN_ALL               (((STRLEN*)0)+1)    /* use warnings 'all' */
                                 ~~~~~~~~~~~~^
re_comp.c:16202:36: warning: performing pointer arithmetic on a null pointer has undefined behavior [-Wnull-pointer-arithmetic]
                                && ckDEAD(packWARN(WARN_REGEXP));
                                   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:231:6: note: expanded from macro 'ckDEAD'
    !specialWARN(PL_curcop->cop_warnings) &&                            \
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:25:13: note: expanded from macro 'specialWARN'
                                 (x) == pWARN_NONE)
                                        ^~~~~~~~~~
../../warnings.h:22:34: note: expanded from macro 'pWARN_NONE'
#define pWARN_NONE              (((STRLEN*)0)+2)    /* no  warnings 'all' */
                                 ~~~~~~~~~~~~^
re_comp.c:16419:23: warning: performing pointer arithmetic on a null pointer has undefined behavior [-Wnull-pointer-arithmetic]
    bool warn_super = ALWAYS_WARN_SUPER;
                      ^~~~~~~~~~~~~~~~~
re_comp.c:578:28: note: expanded from macro 'ALWAYS_WARN_SUPER'
#define ALWAYS_WARN_SUPER  ckDEAD(packWARN(WARN_NON_UNICODE))
                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:231:6: note: expanded from macro 'ckDEAD'
    !specialWARN(PL_curcop->cop_warnings) &&                            \
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:24:53: note: expanded from macro 'specialWARN'
#define specialWARN(x)          ((x) == pWARN_STD || (x) == pWARN_ALL ||        \
                                                            ^~~~~~~~~
../../warnings.h:21:33: note: expanded from macro 'pWARN_ALL'
#define pWARN_ALL               (((STRLEN*)0)+1)    /* use warnings 'all' */
                                 ~~~~~~~~~~~~^
re_comp.c:16419:23: warning: performing pointer arithmetic on a null pointer has undefined behavior [-Wnull-pointer-arithmetic]
    bool warn_super = ALWAYS_WARN_SUPER;
                      ^~~~~~~~~~~~~~~~~
re_comp.c:578:28: note: expanded from macro 'ALWAYS_WARN_SUPER'
#define ALWAYS_WARN_SUPER  ckDEAD(packWARN(WARN_NON_UNICODE))
                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:231:6: note: expanded from macro 'ckDEAD'
    !specialWARN(PL_curcop->cop_warnings) &&                            \
     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../warnings.h:25:13: note: expanded from macro 'specialWARN'
                                 (x) == pWARN_NONE)
                                        ^~~~~~~~~~
../../warnings.h:22:34: note: expanded from macro 'pWARN_NONE'
#define pWARN_NONE              (((STRLEN*)0)+2)    /* no  warnings 'all' */
                                 ~~~~~~~~~~~~^
4 warnings generated.
A failure has been detected in another branch of the parallel make

make[11]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1/ext/re
A failure has been detected in another branch of the parallel make

make[11]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1/ext/re
Unsuccessful make(ext/re): code=512 at make_ext.pl line 570.
*** [lib/auto/re/re.so] Error code 25

make[10]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1
2 errors

make[10]: stopped in /usr/ports/lang/perl5.28/work/perl-5.28.1
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[9]: stopped in /usr/ports/lang/perl5.28
*** Error code 1

Stop.
make[8]: stopped in /usr/ports/devel/p5-Locale-gettext
*** Error code 1

Stop.
make[7]: stopped in /usr/ports/misc/help2man
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/print/texinfo
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/devel/m4
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/autoconf
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/graphics/wayland
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/wayland-protocols
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/xorg
Comment 1 Mathieu Arnold freebsd_committer 2019-01-29 20:45:04 UTC
I cannot reproduce. What are your exact test os version/architecture?
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-05-28 05:09:01 UTC
If this issue is still reproducible, please re-open this bug with additional details (including a full build log as an attachment)