Bug 235356 - devel/jenkins fails to start after upgrade if jenkins home dir is /usr/local/jenkins
Summary: devel/jenkins fails to start after upgrade if jenkins home dir is /usr/local/...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-31 17:05 UTC by Marc Branchaud
Modified: 2019-08-08 02:06 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (lwhsu)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Branchaud 2019-01-31 17:05:34 UTC
(This looks a lot like bug #193670 has re-appeared.)

Using pkg to manage my ports.

The jenkins user's home directory is /usr/local/jenkins.

Prior to a "pkg upgrade", that directory is owned by user & group jenkins:

# cd /usr/local
# ls -ld jenkins
drwxr-xr-x  20 jenkins  jenkins   77 Jan  4 15:27 jenkins

After pkg upgrades the jenkins port, the directory becomes owned by root:

# pkg upgrade jenkins
....
# ls -ld jenkins
drwxr-xr-x  20 root  jenkins   77 Jan  2 17:22 jenkins

This prevents jenkins from starting, as it needs to write to its home directory.

Upgrading other packages does not change this directory's ownership.


The system is 11.2-RELEASE-p3.

pkg is 1.10.5_5

jenkins is currently 2.160, but I've seen this every time I've upgraded jenkins over the last year or so (since the system was created).
Comment 1 Marc Branchaud 2019-01-31 18:41:13 UTC
Forgot to mention: /usr/local/jenkins is a zfs mount:

# zfs list /usr/local/jenkins
NAME             USED  AVAIL  REFER  MOUNTPOINT
storage/builds  10.2T  3.61T  10.2T  /usr/local/jenkins
Comment 2 Li-Wen Hsu freebsd_committer 2019-02-12 06:43:55 UTC
I cannot reproduce this with pkg 1.10.5_5 on 12.0-R for jenkins 1.163 to (upcoming) 1.164.  I'll test on 11.2 later.  If you have a reliable way to reproduce this, please let me know.  Thanks!
Comment 3 Marc Branchaud 2019-02-12 15:14:39 UTC
Well, I can reliably reproduce it on my system.  :)

Is there anything I can do to investigate on my end?  Some logging or verbosity to enable?

Some miscellaneous info:

* root's shell is /usr/local/bin/bash, so "pkg upgrade" runs under bash.

* I login as myself, then do "sudo -i" to become root.

* Here's the full list of installed packages:

aalib-1.4.r5_13
alsa-lib-1.1.2_2
apache24-2.4.38
apr-1.6.5.1.6.1_1
atk-2.28.1
avahi-app-0.7_2
bash-4.4.23_1
ca_root_nss-3.42.1
cairo-1.15.12,2
cdrtools-3.01_1
cups-2.2.10
curl-7.64.0
cvsps-2.1_2
cyrus-sasl-2.1.27
db5-5.3.28_7
dbus-1.10.16_1
dbus-glib-0.108
dejavu-2.37
encodings-1.0.4_4,1
expat-2.2.6_1
font-bh-ttf-1.0.3_3
font-misc-ethiopic-1.0.3_3
font-misc-meltho-1.0.3_3
font-util-1.3.1
fontconfig-2.12.6,1
freetype2-2.9.1
fribidi-0.19.7
gdbm-1.18.1
gdk-pixbuf2-2.36.12
gettext-runtime-0.19.8.1_2
giflib-5.1.4
git-2.20.1
glib-2.56.3_2,1
gmp-6.1.2_1
gnome-pty-helper-0.40.2
gnome_subr-1.0
gnutls-3.6.5
gobject-introspection-1.56.1,1
graphite2-1.3.13
gtk-update-icon-cache-2.24.32
gtk2-2.24.32
harfbuzz-2.3.1
hicolor-icon-theme-0.15
highlight-3.43_4,3
indexinfo-0.3.1
jasper-1.900.1_17
java-zoneinfo-2018.g
javavmwrapper-2.6
jbigkit-2.1_1
jenkins-2.160
jpeg-turbo-2.0.1
libGLU-9.0.0_3
libICE-1.0.9_3,1
libSM-1.2.3,1
libX11-1.6.7,1
libXau-1.0.8_5
libXcomposite-0.4.4_5,1
libXcursor-1.1.15_2
libXdamage-1.1.4_5
libXdmcp-1.1.2_2
libXext-1.3.3_3,1
libXfixes-5.0.3_2
libXft-2.3.2_3
libXi-1.7.9_2,1
libXinerama-1.1.4_2,1
libXmu-1.1.2_5,1
libXrandr-1.5.1_2
libXrender-0.9.10_2
libXt-1.1.5_2,1
libXtst-1.2.3_2
libXxf86vm-1.1.4_3
libdaemon-0.14_1
libdrm-2.4.96,1
libedit-3.1.20170329_2,1
libepoll-shim-0.0.20181229
libffi-3.2.1_3
libfontenc-1.1.3_3
libiconv-1.14_11
libidn2-2.0.5_1
libinotify-20180201_1
liblz4-1.8.3,1
libnghttp2-1.35.1
libpaper-1.1.24.4
libpciaccess-0.13.5
libpthread-stubs-0.4
libtasn1-4.13_1
libunistring-0.9.10_1
libunwind-20170615
libxcb-1.13.1
libxml2-2.9.7
libxshmfence-1.2_4
lua52-5.2.4
mercurial-4.8.1
mesa-libs-18.1.9_4
mkfontdir-1.0.7
mkfontscale-1.1.3_2
nano-3.2
nettle-3.4.1_1
openjdk8-8.192.26_3
p11-kit-0.23.14
p5-Authen-SASL-2.16_1
p5-CGI-4.40
p5-Digest-HMAC-1.03_1
p5-Error-0.17027
p5-GSSAPI-0.28_1
p5-HTML-Parser-3.72
p5-HTML-Tagset-3.20_1
p5-IO-Socket-INET6-2.72_1
p5-IO-Socket-SSL-2.060
p5-Mozilla-CA-20180117
p5-Net-SSLeay-1.85
p5-Socket6-0.29
pango-1.42.4_1
pciids-20181113
pcre-8.42_1
perl5-5.28.1
pixman-0.34.0_1
pkg-1.10.5_5
png-1.6.36
pstree-2.39
py27-setuptools-40.6.2
python-2.7_3,2
python2-2_3
python27-2.7.15
python36-3.6.7
qemu-2.12.1_1
readline-7.0.5
rsync-3.1.3
sdl-1.2.15_13,2
serf-1.3.9_3
shared-mime-info-1.8
sqlite3-3.26.0
ssmtp-2.64_3
subversion-1.11.0_1
sudo-1.8.27
tiff-4.0.10
tpm-emulator-0.7.4_2
trousers-0.3.14_2
utf8proc-2.1.0
vde2-2.3.2_2
vte-0.28.2_3
wayland-1.16.0
wget-1.20
xauth-1.0.10
xcb-util-0.4.0_2,1
xcb-util-renderutil-0.3.9_1
xorg-fonts-truetype-7.7_1
xorgproto-2018.4

Thanks for looking into this!
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-08-08 02:06:22 UTC
We have jenkins version 2.189. I close here.  

If there are still problems, please, reopen.