Bug 235455 - x11/xdm missing dependency
Summary: x11/xdm missing dependency
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-03 08:44 UTC by fehmi noyan isi
Modified: 2019-09-14 19:43 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fehmi noyan isi 2019-02-03 08:44:59 UTC
x11/xdm should have x11/xsm (X Session Manager) in its dependency list as without a session manager x11/xdm fails to start a new session and keeps showing the login dialog.

Installing x11/xsm solves the problem.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-08 01:56:54 UTC
ping!
Comment 2 Niclas Zeising freebsd_committer 2019-08-08 08:54:45 UTC
I am unsure if this fix is right or not.  I will have to look into it.
Comment 3 Niclas Zeising freebsd_committer 2019-08-08 09:03:30 UTC
As far as I can tell, this dependency isn't documented anywhere, and does not exist in any of the linux distros I checked.  In some cases, it isn't even packaged.  I believe xdm in itself can take care of session handling.

I don't think this is a bug.
Comment 4 Andriy Gapon freebsd_committer 2019-08-08 14:24:28 UTC
Yeah, I guess it could be something that the reporter has in their .xsession or .xinitrc. I am able to login via xdm into my kde session without having xsm installed.
Comment 5 Niclas Zeising freebsd_committer 2019-08-08 15:43:57 UTC
(In reply to Andriy Gapon from comment #4)
> Yeah, I guess it could be something that the reporter has in their .xsession
> or .xinitrc. I am able to login via xdm into my kde session without having
> xsm installed.

Hijacking this thread a bit, since you are an xdm user, any chance you can take https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/xorglibs/x11/xdm for a spin?  It's an update of x11/xdm to 1.1.12.  I can create a more convenient patch if you like.
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-08-08 16:39:16 UTC
I am starting "old fashioned" with startx (fvwm-crystal).