Bug 235506 - devel/gsoap: build fail with libressl
Summary: devel/gsoap: build fail with libressl
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks: 232969
  Show dependency treegraph
 
Reported: 2019-02-04 23:22 UTC by rozhuk.im
Modified: 2019-02-20 17:56 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
svn-diff-gsoap-libressl (1.14 KB, patch)
2019-02-11 02:37 UTC, Walter Schwarzenfeld
no flags Details | Diff
patch (2.88 KB, patch)
2019-02-11 09:29 UTC, rozhuk.im
rozhuk.im: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2019-02-04 23:22:37 UTC
...
 "/usr/bin/ld" --eh-frame-hdr -dynamic-linker /libexec/ld-elf.so.1 --hash-style=both --enable-new-dtags -m elf_i386_fbsd -o /tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/tstAsmStructsRC/tstAsmStructsRC -L/usr/lib32 -L/usr/lib32 /usr/lib32/crt1.o /usr/lib32/crti.o /usr/lib32/crtbegin.o /tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/tstAsmStructsRC/tstAsmStructs.o /usr/lib32/crtend.o /usr/lib32/crtn.o /usr/lib32/libc.so
kBuild: Compiling vboxsoap - /usr/local/lib/gsoap/stdsoap2.cpp
/usr/local/lib/gsoap/stdsoap2.cpp:4407:12: error: use of undeclared identifier 'TLS1_3_VERSION'
    minv = TLS1_3_VERSION;
           ^
/usr/local/lib/gsoap/stdsoap2.cpp:4409:12: error: use of undeclared identifier 'TLS1_3_VERSION'
    maxv = TLS1_3_VERSION;
           ^
...
Comment 1 Muhammad Moinur Rahman freebsd_committer 2019-02-06 00:08:17 UTC
Seems like gsoap update to 2.8.78 works well with LibreSSL and TLS 1.3. I am building virtualbox with the new update, it will take a while. Just in case you want to follow.

http://pdr.bofh.network/build.html?mastername=112i386-default&build=2019-02-06_00h01m22s
Comment 2 commit-hook freebsd_committer 2019-02-06 07:00:17 UTC
A commit references this bug:

Author: bofh
Date: Wed Feb  6 06:59:40 UTC 2019
New revision: 492287
URL: https://svnweb.freebsd.org/changeset/ports/492287

Log:
  devel/gsoap: Update version 2.8.74=>2.8.78

  - Fixes virtualbox-se build with libressl [1]

  PR:		235506 [1]
  Reported by:	rozhuk.im@gmail.com [1]

Changes:
  head/devel/gsoap/Makefile
  head/devel/gsoap/distinfo
  head/devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp
  head/devel/gsoap/files/patch-gsoap_plugin_mecevp.c
  head/devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp
  head/devel/gsoap/files/patch-gsoap_stdsoap2.c
  head/devel/gsoap/files/patch-gsoap_stdsoap2.cpp
  head/devel/gsoap/pkg-plist
Comment 3 rozhuk.im 2019-02-06 08:33:35 UTC
Not help:
...
 "/usr/bin/ld" --eh-frame-hdr -dynamic-linker /libexec/ld-elf.so.1 --hash-style=both --enable-new-dtags -m elf_i386_fbsd -o /tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/tstAsmStructsRC/tstAsmStructsRC -L/usr/lib32 -L/usr/lib32 /usr/lib32/crt1.o /usr/lib32/crti.o /usr/lib32/crtbegin.o /tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/tstAsmStructsRC/tstAsmStructs.o /usr/lib32/crtend.o /usr/lib32/crtn.o /usr/lib32/libc.so
kBuild: Compiling vboxsoap - /usr/local/lib/gsoap/stdsoap2.cpp
/usr/local/lib/gsoap/stdsoap2.cpp:4449:12: error: use of undeclared identifier 'TLS1_3_VERSION'
    minv = TLS1_3_VERSION;
           ^
/usr/local/lib/gsoap/stdsoap2.cpp:4451:12: error: use of undeclared identifier 'TLS1_3_VERSION'
    maxv = TLS1_3_VERSION;
           ^
2 errors generated.
kmk: *** [/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/vboxsoap/usr/local/lib/gsoap/stdsoap2.o] Error 1
The failing command:
@c++ -c -O2 -g -pipe -Wshadow -Wall -Wextra -Wno-missing-field-initializers -Wno-unused -Wno-trigraphs -fdiagnostics-show-option -Wno-unused-parameter -Wno-language-extension-token -Wno-gnu-folding-constant -Wno-gnu-anonymous-struct -Wno-string-plus-int -Wno-nested-anon-types -Wno-variadic-macros -Wno-long-long -Wno-variadic-macros -O2 -mtune=generic -fno-omit-frame-pointer -fno-strict-aliasing -Wno-unused-parameter -Wno-shadow -Wno-parentheses    -Wno-vla -Wno-format -Wno-deprecated-declarations -m64 -Wno-format   -I/usr/local/lib/gsoap -I/usr/local/share/gsoap/import -I/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/webservice -I/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/src/VBox/Main/webservice -I/usr/local/include -I/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/vboxsoap/dtrace -I/usr/local/include -I/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/include -I/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release -DVBOX -DVBOX_OSE -DVBOX_WITH_64_BITS_GUESTS -DVBOX_WITH_REM -DVBOX_WITH_RAW_MODE -DRT_OS_FREEBSD -D__FREEBSD__ -DRT_ARCH_AMD64 -D__AMD64__ -DVBOX_WITH_DEBUGGER -DVBOX_WITH_HARDENING -DRTPATH_APP_PRIVATE=\"/usr/local/share/virtualbox-ose\" -DRTPATH_APP_PRIVATE_ARCH=\"/usr/local/lib/virtualbox\" -DRTPATH_SHARED_LIBS=\"/usr/local/lib/virtualbox\" -DRTPATH_APP_DOCS=\"/usr/local/share/doc/virtualbox-ose\" -DIN_RING3 -DHC_ARCH_BITS=64 -DGC_ARCH_BITS=64 -DWITH_OPENSSL -Wp,-MD,/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/vboxsoap/usr/local/lib/gsoap/stdsoap2.o.dep -Wp,-MT,/tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/vboxsoap/usr/local/lib/gsoap/stdsoap2.o -Wp,-MP -o /tmp/ports/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.2.26/out/freebsd.amd64/release/obj/vboxsoap/usr/local/lib/gsoap/stdsoap2.o /usr/local/lib/gsoap/stdsoap2.cpp
...
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-02-06 11:05:45 UTC
Onl y for info: see bug #234878- 

https://www.virtualbox.org/wiki/Downloads
Please also use version 5.2 if you still need support for 32-bit hosts, as this has been discontinued in 6.0. Version 5.2 will remain supported until July 2020
Comment 5 Muhammad Moinur Rahman freebsd_committer 2019-02-07 12:19:03 UTC
(In reply to rozhuk.im from comment #3)
I am not sure how you built curl with libressl. curl is a dependency for virtualbox-ose.
Comment 6 rozhuk.im 2019-02-08 13:58:31 UTC
libressl does not have TLS1_3_VERSION definition.
Comment 7 Walter Schwarzenfeld freebsd_triage 2019-02-11 02:37:31 UTC
Created attachment 201913 [details]
svn-diff-gsoap-libressl

i take the simplest idea. I cannot reproduce the error, but try this one.
Comment 8 rozhuk.im 2019-02-11 09:29:32 UTC
Created attachment 201924 [details]
patch

This helps me.
Comment 9 Muhammad Moinur Rahman freebsd_committer 2019-02-14 12:34:11 UTC
Can anyone please confirm which one to go with. Both compiles perfectly.
Comment 10 Walter Schwarzenfeld freebsd_triage 2019-02-14 13:30:49 UTC
Take rozhuks solution, it is a "general" solution.
Comment 11 commit-hook freebsd_committer 2019-02-20 17:55:41 UTC
A commit references this bug:

Author: bofh
Date: Wed Feb 20 17:55:30 UTC 2019
New revision: 493429
URL: https://svnweb.freebsd.org/changeset/ports/493429

Log:
  devel/gsoap: Update version 2.8.78=>2.8.79

  - Fix build with libressl [1]

  PR:		235506 [1]
  Submitted by:	rozhuk.im@gmail.com [1]

Changes:
  head/devel/gsoap/Makefile
  head/devel/gsoap/distinfo
  head/devel/gsoap/files/patch-gsoap_VisualStudio2005_wsdl2h_wsdl2h_stdsoap2.cpp
  head/devel/gsoap/files/patch-gsoap_samples_calc__vs2005_calc__vs2005_stdsoap2.cpp
  head/devel/gsoap/files/patch-gsoap_stdsoap2.c
  head/devel/gsoap/files/patch-gsoap_stdsoap2.cpp