Bug 235555 - audio/lmms drag/drop broken on Qt 5.12.0
Summary: audio/lmms drag/drop broken on Qt 5.12.0
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Rodrigo Osorio
URL: https://github.com/LMMS/lmms/issues/4738
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-02-06 15:40 UTC by renshencha
Modified: 2019-02-12 19:44 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (rodrigo)


Attachments
v1 (8.06 KB, patch)
2019-02-06 17:47 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description renshencha 2019-02-06 15:40:44 UTC
Drag/drop is completely broken on port audio/lmms 1.2.0-rc7, Qt 5.12.0
According to a thread on Github due to changes/bugs in Qt 5.12.0
https://github.com/LMMS/lmms/issues/4738
Comment 1 Tobias Kortkamp freebsd_committer 2019-02-06 15:50:49 UTC
CC kde@ as this appears to be due to a regression in Qt 5.12.0.

https://bugreports.qt.io/browse/QTBUG-72844
https://codereview.qt-project.org/#/c/249086/
Comment 2 Tobias C. Berner freebsd_committer 2019-02-06 17:47:25 UTC
Created attachment 201794 [details]
v1

Hi

Could you give the attached (untested) patch a try?


mfg Tobias
Comment 3 renshencha 2019-02-06 18:21:14 UTC
(In reply to Tobias C. Berner from comment #2)
Thanks! Patch applied and compiling now, I'll update when I've tested it out.
Comment 4 renshencha 2019-02-06 18:54:10 UTC
(In reply to Tobias C. Berner from comment #2)

So I have never patched or anything before and perhaps I'm not doing it correctly. I've recompiled qt5-widgets and it's on version qt5-widgets-5.12.0_3 now. Also recompiled lmms after that and no difference for me.
Comment 5 Rodrigo Osorio freebsd_committer 2019-02-07 04:03:09 UTC
Hi,

Probably the current issue was fixed in latest QT release 5.12.1 (released on February the 1st). The LMMS bug report only stand on an issue with 5.12.0 and Arch team report a fix patching that version.

That probably explains why the patch added in comment #2, done after 5.12.1 release, don't seems to fix the problem. 

All the details about the latest QT relase
https://blog.qt.io/blog/2019/02/01/qt-5-12-1-released/

Filtering the fixes coming in the release shows that many of them fix drag and drop breakages : 
https://bugreports.qt.io/browse/QTBUG-70544?filter=20530&jql=project%20%3D%20QTBUG%20AND%20issuetype%20%3D%20Bug%20AND%20resolution%20in%20(Done%2C%20Fixed)%20AND%20fixVersion%20%3D%205.12.1%20AND%20text%20~%20%22drop%22%20ORDER%20BY%20priority%20DESC%2C%20status%20ASC%2C%20labels%20ASC
Comment 6 Tobias C. Berner freebsd_committer 2019-02-07 05:33:22 UTC
(In reply to Rodrigo Osorio from comment #5)
I missed the release announcement. I'll prepare an update to Qt5 shortly.
Comment 7 Rodrigo Osorio freebsd_committer 2019-02-07 07:51:30 UTC
(In reply to Tobias C. Berner from comment #6)

Great ! BTW I was wrong about the patch chronology. The patch you point seems to be part of the latest release, but maybe it's not sufficient by itself :P.

@renshencha : QT update will require a exp-run and could take some time to come up. You probably won't see a new version before next week.

I keep this PR open to track evolution and see after QT update if something else hasn't to be done in LMMS itself.
Comment 8 Tobias C. Berner freebsd_committer 2019-02-09 11:01:52 UTC
If you are interested to see whether 5.12.1 fixes it, you can get the ports from here: 
https://github.com/freebsd/freebsd-ports-kde/tree/qt5-5.12.1


mfg Tobias
Comment 9 Tobias C. Berner freebsd_committer 2019-02-12 17:57:34 UTC
Qt5 5.12.1 has landed in ports -- can you try if it works now?


mfg Tobias
Comment 10 renshencha 2019-02-12 19:42:53 UTC
(In reply to Tobias C. Berner from comment #9)
Confirmed, lmms works properly on Qt5 5.12.1
Comment 11 Rodrigo Osorio freebsd_committer 2019-02-12 19:44:27 UTC
(In reply to renshencha from comment #10)
Excellent, good job everyone !