Bug 235631 - net-mgmt/zabbix4-server cannot build with MariaDB 10.3
Summary: net-mgmt/zabbix4-server cannot build with MariaDB 10.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo G. Baio
URL:
Keywords:
: 236463 (view as bug list)
Depends on: 235744
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-09 23:45 UTC by Miroslav Lachman
Modified: 2019-03-24 20:26 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (pg)


Attachments
build log failure (330.70 KB, text/plain)
2019-02-09 23:45 UTC, Miroslav Lachman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Lachman 2019-02-09 23:45:38 UTC
Created attachment 201880 [details]
build log failure

I am trying to build Zabbix 4 and Zabbix 3.4 in poudriere on FreeBSD 11.2 with MariaDB 10.3. Both versions (4.0 and 3.4) failed with the same error:

checking for architecture... freebsd (freebsd11.2)
checking size of void *... 8
checking for mysql_config... /usr/local/bin/mysql_config
checking for main in -lmariadb... no
configure: error: Not found mariadb library
===>  Script "configure" failed unexpectedly.


This is make.conf for Poudriere

OPTIONS_UNSET= X11 GUI CUPS DOCS EXAMPLES NLS HAL

DEFAULT_VERSIONS=apache=2.4 perl5=5.28 mysql=10.3m php=7.1 python=2.7 python3=3.6 pgsql=9.6 ssl=openssl bdb=5


And Zabbix options

---Begin OPTIONS List---
===> The following configuration options are available for zabbix34-server-3.4.15:
     CURL=on: Support for web monitoring
     FPING=on: Build/install fping for ping checks
     IPMI=on: Support for IPMI checks
     IPV6=on: IPv6 protocol support
     JABBER=off: Support for Jabber media type
     LDAP=off: Support for LDAP server checks
     LIBXML2=off: Support for libxml2 (required by monitoring VMware)
     NMAP=on: Build/install nmap for o/s detection
     SSH=on: Support for SSH-based checks
====> Options available for the single DB: you have to select exactly one of them
     MYSQL=on: MySQL database support
     PGSQL=off: PostgreSQL database support
     SQLITE=off: SQLite database support
     ORACLE=off: Oracle database support
====> Support for database checks via ODBC: you have to select exactly one of them
     IODBC=off: ODBC backend via iODBC
     UNIXODBC=on: ODBC backend via unixODBC
====> SSL protocol support: you have to select exactly one of them
     OPENSSL=on: SSL/TLS support via OpenSSL
     GNUTLS=off: SSL/TLS support via GnuTLS
===> Use 'make config' to modify these settings
---End OPTIONS List---


I found similar reports on the net but they were for older versions, marked as fixed more then year ago.

I am using / building Zabbix with the same settings with MariaDB 10.1 without problem. 



I tried to build it manually in /usr/ports but the same error occurred:

checking for -rdynamic linking option... yes
checking for libperfstat 5.2.0.40 fileset... no
checking for libperfstat 5.3.0.60 fileset... no
checking for architecture... freebsd (freebsd11.2)
checking size of void *... 8
checking for mysql_config... /usr/local/bin/mysql_config
checking for main in -lmariadb... no
configure: error: Not found mariadb library
===>  Script "configure" failed unexpectedly.
Please report the problem to pg@pakhom.spb.ru [maintainer] and attach the
"/var/ports/usr/ports/default/net-mgmt/zabbix4-server/work/zabbix-4.0.3/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/default/net-mgmt/zabbix4-server
*** Error code 1

Stop.
make: stopped in /usr/ports/default/net-mgmt/zabbix4-server
Comment 1 Miroslav Lachman 2019-02-23 21:40:41 UTC
Thank you  Danilo G. Baio.
I can confirm that your patch in PR 235744 fixed the build of Zabbix4.
Comment 2 Danilo G. Baio freebsd_committer 2019-03-23 00:56:06 UTC
*** Bug 236463 has been marked as a duplicate of this bug. ***
Comment 3 Danilo G. Baio freebsd_committer 2019-03-24 20:26:34 UTC
Seems that ports r496689 fixed this problem, I tested with poudriere and it built fine.

Any problems, let us know.