Bug 235634 - security/p5-GSSAPI fails to build with OpenSSL from ports
Summary: security/p5-GSSAPI fails to build with OpenSSL from ports
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: powerpc Any
: --- Affects Only Me
Assignee: freebsd-perl mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-10 06:37 UTC by Dennis Clarke
Modified: 2019-02-10 19:03 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Clarke 2019-02-10 06:37:01 UTC
While trying to build git :

...
===>  Configuring for p5-Digest-HMAC-1.03_1
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Digest::HMAC
Writing MYMETA.yml and MYMETA.json
===>  Building for p5-Digest-HMAC-1.03_1
--- blib/lib/Digest/.exists ---
--- blib/arch/.exists ---
--- blib/lib/auto/Digest/HMAC/.exists ---
--- blib/arch/auto/Digest/HMAC/.exists ---
--- blib/bin/.exists ---
--- blib/script/.exists ---
--- blib/man1/.exists ---
--- blib/man3/.exists ---
--- config ---
--- subdirs ---
--- dynamic ---
--- pm_to_blib ---
--- blibdirs ---
--- config ---
--- dynamic ---
--- linkext ---
--- pm_to_blib ---
cp lib/Digest/HMAC_MD5.pm blib/lib/Digest/HMAC_MD5.pm
cp lib/Digest/HMAC.pm blib/lib/Digest/HMAC.pm
cp lib/Digest/HMAC_SHA1.pm blib/lib/Digest/HMAC_SHA1.pm
--- pure_all ---
--- manifypods ---
Manifying 3 pod documents
--- all ---
===>  Staging for p5-Digest-HMAC-1.03_1
===>   p5-Digest-HMAC-1.03_1 depends on package: perl5>=5.28.r1<5.29 - found
===>   Generating temporary packing list
Manifying 3 pod documents
Installing /usr/ports/security/p5-Digest-HMAC/work/stage/usr/local/lib/perl5/site_perl/Digest/HMAC_MD5.pm
Installing /usr/ports/security/p5-Digest-HMAC/work/stage/usr/local/lib/perl5/site_perl/Digest/HMAC.pm
Installing /usr/ports/security/p5-Digest-HMAC/work/stage/usr/local/lib/perl5/site_perl/Digest/HMAC_SHA1.pm
Installing /usr/ports/security/p5-Digest-HMAC/work/stage/usr/local/lib/perl5/site_perl/man/man3/Digest::HMAC.3
Installing /usr/ports/security/p5-Digest-HMAC/work/stage/usr/local/lib/perl5/site_perl/man/man3/Digest::HMAC_MD5.3
Installing /usr/ports/security/p5-Digest-HMAC/work/stage/usr/local/lib/perl5/site_perl/man/man3/Digest::HMAC_SHA1.3
====> Compressing man pages (compress-man)
===>  Installing for p5-Digest-HMAC-1.03_1
===>  Checking if p5-Digest-HMAC is already installed
===>   Registering installation for p5-Digest-HMAC-1.03_1 as automatic
Installing p5-Digest-HMAC-1.03_1...
===>   p5-Authen-SASL-2.16_1 depends on package: p5-Digest-HMAC>0 - found
===>   Returning to build of p5-Authen-SASL-2.16_1
===>   p5-Authen-SASL-2.16_1 depends on package: p5-GSSAPI>0 - not found
===>  p5-GSSAPI-0.28_1 You are using OpenSSL from ports and have selected
GSSAPI from base, please select another GSSAPI value.
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/security/p5-GSSAPI
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/security/p5-Authen-SASL
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/security/p5-Authen-SASL
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/git
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/git
hydra# 

This is a strange message and not helpful at all.

hydra# cd /usr/ports/security/p5-GSSAPI
hydra# make install
===>  p5-GSSAPI-0.28_1 You are using OpenSSL from ports and have selected
GSSAPI from base, please select another GSSAPI value.
*** Error code 1

Stop.
make: stopped in /usr/ports/security/p5-GSSAPI
hydra# 

Right so ? 

select another GSSAPI value?

OKay .. how about 5 ? Would '5' work?
Comment 1 w.schwarzenfeld freebsd_triage 2019-02-10 10:45:03 UTC
This is no bug.

=> p5-GSSAPI-0.28_1 You are using OpenSSL from ports and have selected
GSSAPI from base, please select another GSSAPI value.

make.config:

====> GSSAPI Security API support: you have to select exactly one of them
     GSSAPI_BASE=off: GSSAPI support via base system (needs Kerberos)
     GSSAPI_HEIMDAL=on: GSSAPI support via security/heimdal  <=this is default.
     GSSAPI_MIT=off: GSSAPI support via security/krb5
===> Use 'make config' to modify these settings
Comment 2 w.schwarzenfeld freebsd_triage 2019-02-10 10:46:34 UTC
Sorry was wrong default is GSSAPI_BASE=on. But you have to change it if you use openssl from ports.
Comment 3 Dennis Clarke 2019-02-10 15:48:42 UTC
This is a bug because of other bugs. 

Let me explain by showing : 

    233225 libssl.so.8 not found by pkg
    234481 ports-mgmt/pkg unable to find libssl.so.8 on RPI3 on 12

123456789+123456789+123456789+123456789+123456789+123456789+123456789+12
This means FreeBSD 12.0 RELEASE is broken by design on day zero from
install because pkg is broken.  No one can install software.  So a
person is forced to build OpenSSL from ports and then the other few
dependencies for pkg to work. If one then later needs git or similar
we need to get security/p5-GSSAPI installed.  However no one can do
that because :

hydra# cd /usr/ports/security/p5-GSSAPI
hydra# make install
===>  p5-GSSAPI-0.28_1 You are using OpenSSL from ports and have selected
GSSAPI from base, please select another GSSAPI value.
*** Error code 1

Stop.
make: stopped in /usr/ports/security/p5-GSSAPI
hydra# 

So where is the problem?  So where is the fix? 

This is a "bug" in the most true sense.
Comment 4 Dennis Clarke 2019-02-10 16:18:57 UTC
hydra# pwd
/usr/ports/security/p5-GSSAPI

hydra# make config
        p5-GSSAPI-0.28_1
            GSSAPI Security API support
                +( ) GSSAPI_BASE     GSSAPI support via base system (needs Kerberos)
                +( ) GSSAPI_HEIMDAL  GSSAPI support via security/heimdal
                +(*) GSSAPI_MIT      GSSAPI support via security/krb5

One oprion MUST be selected and the default is GSSAPI_BASE which then breaks stuff later on.
Comment 5 w.schwarzenfeld freebsd_triage 2019-02-10 19:03:41 UTC
You need one option per default on. And the "best" is GSSAPI_BASE. You need it for the packages.
You cannot provide packages without one option on. GSSAPI_HEIMDAL and GSSAPI_MIT would break more packages. I think there is no way out.