Bug 235636 - archivers/arj: build error: Abort trap after upgrading to FreeBSD 12.0
Summary: archivers/arj: build error: Abort trap after upgrading to FreeBSD 12.0
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Renato Botelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-10 08:08 UTC by Peter Putzer
Modified: 2019-03-29 20:56 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (garga)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Putzer 2019-02-10 08:08:55 UTC
After upgrading a server to FreeBSD 12.0, I cannot build arj anymore. It seems like the issue is the same as bug #219716, which is supposed to have been fixed. I've tried all three locale config options.

...
/usr/local/libexec/ccache/world/cc -DLOCALE=LANG_en -DLOCALE_DESC="\"en\"" -DPKGLIBDIR="\"/usr/local/lib/arj\"" -D_UNIX -O3 -pipe -funroll-loops -march=native  -fstack-protector -fno-strict-aliasing  -fstack-protector  -s gnu/stripgcc.lnk -o freebsd12.0/en/rs/tools/msgbind ./freebsd12.0/en/rs/tools/filemode.o ./freebsd12.0/en/rs/tools/msgbind.o ./freebsd12.0/en/rs/tools/arjdata.o ./freebsd12.0/en/rs/tools/crc32.o 
./freebsd12.0/en/rs/tools/msgbind ./resource/resource.txt msg_crp UNIX s en ./freebsd12.0/en/rs
gmake[3]: *** [GNUmakefile:258: freebsd12.0/en/rs/msg_crp.h] Abort trap
gmake[3]: Leaving directory '/var/ports/usr/ports/archivers/arj/work/arj-3.10.22'
gmake[2]: *** [GNUmakefile:169: all] Error 2
gmake[2]: Leaving directory '/var/ports/usr/ports/archivers/arj/work/arj-3.10.22'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/archivers/arj
*** Error code 1

Stop.
make: stopped in /usr/ports/archivers/arj
Comment 1 Peter Putzer 2019-02-10 08:13:34 UTC
OK, I've now review bug #219716 more closely and it appears to be something different. (Not sure if it makes a difference, but "WITH_LLD_IS_LD=yes" is NOT set in my make.conf.)
Comment 2 Renato Botelho freebsd_committer 2019-02-25 13:42:59 UTC
I couldn't reproduce this issue on FreeBSD 12.0 amd64. what is the content of your /etc/make.conf?
Comment 3 Peter Putzer 2019-02-25 15:35:11 UTC
(In reply to Renato Botelho from comment #2)

DEFAULT_VERSIONS= bdb=5 perl5=5.28 mysql=10.3m php=7.2 ruby=2.4 ssl=libressl
CPUTYPE?=native
CFLAGS= -O3 -pipe -funroll-loops

INDEXDIR=               /usr/ports
WRKDIRPREFIX=           /var/ports
DISTDIR=                /var/ports/distfiles
PACKAGES=               /var/ports/packages

OPTIONS_UNSET=X11 GSSAPI_BASE
OPTIONS_SET= GSSAPI_MIT
WITH_PKGNG=yes
WITH_CCACHE_BUILD=yes
WITH_LIBCPLUSPLUS=yes
Comment 4 Renato Botelho freebsd_committer 2019-03-29 13:12:27 UTC
Even with the same make.conf I couldn't reproduce this failure
Comment 5 Peter Putzer 2019-03-29 20:56:20 UTC
(In reply to Renato Botelho from comment #4)

Well, I tried to check again from scratch and did a `make distclean`, no the port is broken again (arj_3.10.22-17.debian.tar.xz is not available anymore).