Bug 235691 - devel/boost-libs : ASIO closing SSL connections incorrect
Summary: devel/boost-libs : ASIO closing SSL connections incorrect
Status: Closed DUPLICATE of bug 235956
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-12 11:01 UTC by Tilman Keskinoz
Modified: 2019-04-18 01:26 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
patch for files directory (407 bytes, patch)
2019-02-12 11:01 UTC, Tilman Keskinoz
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tilman Keskinoz freebsd_committer 2019-02-12 11:01:48 UTC
Created attachment 201952 [details]
patch for files directory

On connection close no TLS alert is sent.

Bug was reported upstream, but upstream appears to be dormant. So I would like to add this patch to our port.

https://svn.boost.org/trac10/ticket/9261
https://github.com/boostorg/asio/issues/189
https://github.com/boostorg/asio/pull/193
Comment 2 Jan Beich freebsd_committer 2019-03-17 19:24:40 UTC
Backporting upstream changes is fine. However, given Asio is header-only library it's not clear where to bump PORTREVISION.
Comment 3 Jan Beich freebsd_committer 2019-04-18 01:26:10 UTC
Already included in Boost 1.70.

*** This bug has been marked as a duplicate of bug 235956 ***