Bug 235776 - security/openvpn-auth-ldap fix for building with openssl111 on FreeBSD11.2S
Summary: security/openvpn-auth-ldap fix for building with openssl111 on FreeBSD11.2S
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-16 07:40 UTC by dewayne
Modified: 2019-07-13 09:00 UTC (History)
0 users

See Also:
mandree: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dewayne 2019-02-16 07:40:17 UTC
Problem (build from make on either i386 or amd64):
security/openvpn-auth-ldap
checking for openssl... no
configure: error: in `/var/ports/usr/ports/security/openvpn-auth-ldap/work/auth-ldap-2.0.4.0.s1379':
configure: error: Could not locate a working OpenSSL library installation. Try --with-openssl=
See `config.log' for more details

Solution
# svnlite diff /usr/ports/security/openvpn-auth-ldap
Index: /usr/ports/security/openvpn-auth-ldap/Makefile
===================================================================
--- /usr/ports/security/openvpn-auth-ldap/Makefile      (revision 492999)
+++ /usr/ports/security/openvpn-auth-ldap/Makefile      (working copy)
@@ -24,7 +24,7 @@
 USE_OPENLDAP=  yes
 CONFIGURE_ARGS+=       --with-openldap=${LOCALBASE} \
                        --with-openvpn=${LOCALBASE}/include \
-                       --with-objc-runtime=GNU
+                       --with-objc-runtime=GNU  --with-openssl=${LOCALBASE}

 PORTDOCS=      README
 PORTEXAMPLES=  auth-ldap.conf

Compiles cleanly on both i386 & amd64.
Comment 1 Matthias Andree freebsd_committer 2019-02-16 08:04:59 UTC
How would this continue to work with OpenSSL from base?
Comment 2 Matthias Andree freebsd_committer 2019-07-13 08:59:46 UTC
Dewayne,

I cannot reproduce your issue, and it does not seem that OpenVPN-Auth-LDAP itself uses crypto/ssl, so it appears that this is only necessary for linking OpenLDAP's libldap.so.

So, to give it the benefit of the doubt, I'll add USES=ssl and --with-openssl=${OPENSSLBASE} which should be safe and cover all situations.
Comment 3 commit-hook freebsd_committer 2019-07-13 09:00:23 UTC
A commit references this bug:

Author: mandree
Date: Sat Jul 13 08:59:26 UTC 2019
New revision: 506524
URL: https://svnweb.freebsd.org/changeset/ports/506524

Log:
  Add OpenSSL base dir to CONFIGURE_ARGS.

  WHile I cannot reproduce the issue, it seems harmless and may help
  certain system configurations.

  PR:		235776
  Submitted by:	dewayne@heuristicsystems.com.au

Changes:
  head/security/openvpn-auth-ldap/Makefile