Bug 235826 - [NEW PORT] lang/ruby26: Object-oriented interpreted scripting language
Summary: [NEW PORT] lang/ruby26: Object-oriented interpreted scripting language
Status: Closed DUPLICATE of bug 234509
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ruby (Nobody)
URL:
Keywords: feature, needs-qa
Depends on: 230289 230436 235795 235796
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-18 03:14 UTC by Yasuhiro Kimura
Modified: 2019-05-09 01:29 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (ruby)


Attachments
Patch file (178.17 KB, patch)
2019-02-18 03:14 UTC, Yasuhiro Kimura
no flags Details | Diff
Updated patch file (178.60 KB, patch)
2019-02-20 06:35 UTC, Yasuhiro Kimura
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro Kimura 2019-02-18 03:14:39 UTC
Created attachment 202118 [details]
Patch file

This is version 2.6 of Ruby.                                                                                                                                                                                                                              Please take following steps to apply attached patch.                                                                                                                                                                                                      
1. cd /usr/ports                                                                                                             2. svn copy lang/ruby25 lang/ruby26                                                                                          3. svn patch /path/to/attached/patch                                                                                                                                                                                                                      And this port depends on following bug reports. So please commit                                                             
together.                                                                                                                                                                                                                                                 * Bug #230289                                                                                                                * Bug #230436                                                                                                                * Bug #235795                                                                                                                * Bug #235796
Comment 1 Yasuhiro Kimura 2019-02-20 06:35:33 UTC
Created attachment 202177 [details]
Updated patch file

Update patch to reflect feedback by private mail.

* Update Mk/bsd.ruby.mk so 'RUBY26=${RUBY26}' is added to PLIST_SUB.
* Don't remove libexec/bundler* at post-patch because it doesn't effect to installed files.
Comment 2 Koichiro Iwao freebsd_committer 2019-04-03 13:36:52 UTC
Can you discuss with pete@nomadlogic.org about which of you work on Ruby 2.6 port?
As already suggested by Kubilay, consider using Phabricator.

*** This bug has been marked as a duplicate of bug 234509 ***
Comment 3 commit-hook freebsd_committer 2019-05-09 01:29:20 UTC
A commit references this bug:

Author: meta
Date: Thu May  9 01:28:40 UTC 2019
New revision: 501068
URL: https://svnweb.freebsd.org/changeset/ports/501068

Log:
  Add ruby26 2.6.3 (copied from ruby25)

  PR:		234509 235826
  Submitted by:	pete@nomadlogic.org (initial revision)
  		Yasuhiro KIMURA <yasu@utahime.org> (initial revision)
  		meta (myself, minor modifications)
  Relnotes::	https://www.ruby-lang.org/en/news/2018/12/25/ruby-2-6-0-released/
  		https://www.ruby-lang.org/en/news/2019/01/30/ruby-2-6-1-released/
  		https://www.ruby-lang.org/en/news/2019/03/13/ruby-2-6-2-released/
  		https://www.ruby-lang.org/en/news/2019/04/17/ruby-2-6-3-released/
  Differential Revision:	https://reviews.freebsd.org/D19961

Changes:
  head/Mk/bsd.default-versions.mk
  head/Mk/bsd.ruby.mk
  head/lang/ruby26/
  head/lang/ruby26/Makefile
  head/lang/ruby26/distinfo
  head/lang/ruby26/files/patch-configure.ac
  head/lang/ruby26/files/patch-tool_rbinstall.rb
  head/lang/ruby26/pkg-message
  head/lang/ruby26/pkg-plist