Bug 235857 - print/texinfo: how to fix size mismatch texinfo/6.5/htmlxref.cnf and texinfo.tex
Summary: print/texinfo: how to fix size mismatch texinfo/6.5/htmlxref.cnf and texinfo.tex
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
: 235913 239696 240199 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-19 09:53 UTC by Adam Heinrich
Modified: 2019-08-30 09:17 UTC (History)
5 users (show)

See Also:
tobik: maintainer-feedback? (sunpoet)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Heinrich 2019-02-19 09:53:12 UTC
root@developement:/usr/ports/www/hiawatha # make install clean BATCH=yes
===>   hiawatha-10.8.2_1 depends on file: /usr/local/bin/cmake - not found
===>   cmake-3.12.2 depends on package: py27-sphinx>0 - found
===>   cmake-3.12.2 depends on shared library: libcurl.so - not found
===>   curl-7.62.0 depends on executable: gmake - found
===>   curl-7.62.0 depends on package: pkgconf>=1.3.0_1 - found
===>   curl-7.62.0 depends on package: perl5>=5.26<5.27 - found
===>   curl-7.62.0 depends on shared library: libnghttp2.so - not found
===>   libnghttp2-1.33.0 depends on package: autoconf>=2.69 - not found
===>   autoconf-2.69_1 depends on executable: gm4 - not found
===>   m4-1.4.18,1 depends on executable: makeinfo - not found
===>  License GPLv3+ accepted by the user
===>   texinfo-6.5,1 depends on file: /usr/local/sbin/pkg - found
=> htmlxref.cnf doesn't seem to exist in /usr/ports/distfiles/texinfo/6.5.
=> Attempting to fetch http://distcache.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf
fetch: http://distcache.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf: size mismatch: expected 20137, actual 20076
=> Attempting to fetch http://distcache.us-east.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf
fetch: http://distcache.us-east.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf: size mismatch: expected 20137, actual 20076
=> Attempting to fetch http://distcache.eu.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf
fetch: http://distcache.eu.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf: size mismatch: expected 20137, actual 20076
=> Attempting to fetch http://distcache.us-west.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf
fetch: http://distcache.us-west.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.5/htmlxref.cnf: size mismatch: expected 20137, actual 20076
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/texinfo/6.5/htmlxref.cnf
fetch: http://distcache.FreeBSD.org/ports-distfiles/texinfo/6.5/htmlxref.cnf: size mismatch: expected 20137, actual 20076
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/texinfo/6.5 and try again.
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/print/texinfo
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/devel/m4
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/autoconf
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/www/libnghttp2
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/ftp/curl
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/cmake
*** Error code 1

Stop.
make: stopped in /usr/ports/www/hiawatha
root@developement:/usr/ports/www/hiawatha #
Comment 1 Tobias Kortkamp freebsd_committer 2019-02-19 10:13:04 UTC
This is a problem in print/texinfo not www/hiawatha, so assign to sunpoet@.

However that you have hiawatha 10.8.2_1 suggests that you have a pretty
out of date ports tree from last year, which we do not really support.
I'd suggest updating it.  The problem has probably been fixed already
in ports r490179.  I can fetch print/texinfo's distfiles just fine.
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-02-19 10:18:14 UTC
You have an outdated ports tree. You're trying to build texinfo 6.5,1 while the latest version is 6.5_4,1 (both head and quarterly branch). Please update the ports tree and it should be fine.
Comment 3 Adriaan de Groot freebsd_committer 2019-02-19 10:19:06 UTC
As tobik@ points out, this is an old ports tree. Please update your tree, so that you get this commit, which updated the file and updated distinfo for the new file size.

r490179 | sunpoet | 2019-01-13 21:08:00 +0100 (Sun, 13 Jan 2019) | 9 lines

Update htmlxref.cnf and texinfo.tex

- Update htmlxref.cnf from 2016-07-11.22 to 2018-08-23.18
Comment 4 Tobias Kortkamp freebsd_committer 2019-02-23 05:08:52 UTC
*** Bug 235913 has been marked as a duplicate of this bug. ***
Comment 5 Tobias Kortkamp freebsd_committer 2019-08-07 14:38:40 UTC
*** Bug 239696 has been marked as a duplicate of this bug. ***
Comment 6 Tobias Kortkamp freebsd_committer 2019-08-30 09:17:30 UTC
*** Bug 240199 has been marked as a duplicate of this bug. ***