Bug 235900 - accessibility/qt5-speech: doesn't build (Unknown module(s) in QT: multimedia)
Summary: accessibility/qt5-speech: doesn't build (Unknown module(s) in QT: multimedia)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-20 22:38 UTC by lumiwa
Modified: 2019-02-24 09:31 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lumiwa 2019-02-20 22:38:13 UTC
My system: FreeBSD 12.0-RELEASE-p3 (amd64). I tried to build port QT5-speech and I got:

===>  Configuring for qt5-speech-5.12.1
/bin/mkdir -p /usr/ports/accessibility/qt5-speech/work/.build
echo 'CMAKE_MODULE_TESTS = -' > /usr/ports/accessibility/qt5-speech/work/.build/.qmake.cache
echo 'QMAKE_LIBDIR_FLAGS = -L/usr/ports/accessibility/qt5-speech/work/.build/lib' >> /usr/ports/accessibility/qt5-speech/work/.build/.qmake.cache
echo 'QMAKE_DEFAULT_LIBDIRS = /usr/local/lib' >> /usr/ports/accessibility/qt5-speech/work/.build/.qmake.cache
echo 'QMAKE_DEFAULT_INCDIRS = /usr/local/include' >> /usr/ports/accessibility/qt5-speech/work/.build/.qmake.cache
Info: creating stash file /usr/ports/accessibility/qt5-speech/work/.build/.qmake.stash
Checking for flite... yes
Checking for flite_alsa... yes
Reading /usr/ports/accessibility/qt5-speech/work/qtspeech-everywhere-src-5.12.1/src/src.pro [/usr/ports/accessibility/qt5-speech/work/.build/src]
Reading /usr/ports/accessibility/qt5-speech/work/qtspeech-everywhere-src-5.12.1/src/tts/tts.pro [/usr/ports/accessibility/qt5-speech/work/.build/src/tts]
Reading /usr/ports/accessibility/qt5-speech/work/qtspeech-everywhere-src-5.12.1/src/plugins/plugins.pro [/usr/ports/accessibility/qt5-speech/work/.build/src/plugins]
  Reading /usr/ports/accessibility/qt5-speech/work/qtspeech-everywhere-src-5.12.1/src/plugins/tts/tts.pro [/usr/ports/accessibility/qt5-speech/work/.build/src/plugins/tts]
   Reading /usr/ports/accessibility/qt5-speech/work/qtspeech-everywhere-src-5.12.1/src/plugins/tts/speechdispatcher/speechdispatcher.pro [/usr/ports/accessibility/qt5-speech/work/.build/src/plugins/tts/speechdispatcher]
   Reading /usr/ports/accessibility/qt5-speech/work/qtspeech-everywhere-src-5.12.1/src/plugins/tts/flite/flite.pro [/usr/ports/accessibility/qt5-speech/work/.build/src/plugins/tts/flite]
Project ERROR: Unknown module(s) in QT: multimedia
*** Error code 3

Thank you.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-02-20 23:06:24 UTC
Try add multimedia to USE_QT in the Makefile.
Comment 2 Tobias C. Berner freebsd_committer 2019-02-21 05:18:25 UTC
Moin moin

That issue has been reported recently on the mailing list, and it happens if flite ist installed and speech picks it up as a backend, requiring a further dependency itself.

I'll commit a fix this weekend.


mfg Tobias
Comment 3 lumiwa 2019-02-21 22:53:14 UTC
(In reply to w.schwarzenfeld from comment #1)
It works for me. Thank you.
Comment 4 commit-hook freebsd_committer 2019-02-24 09:30:05 UTC
A commit references this bug:

Author: tcberner
Date: Sun Feb 24 09:29:04 UTC 2019
New revision: 493747
URL: https://svnweb.freebsd.org/changeset/ports/493747

Log:
  accessibility/qt5-speech: add options SPEECHD and FLITE

  Previously we only assumed to build the speechd backend. If however flite was
  installed, it would be picked up and could leed to it failing due to a missing
  dependency to qt5-multimedia required by said backend.

  With this we add options to deterministically toggle which of the backends to
  build.

  PR:		235900
  Reported by:	starikarp@dismail.de, lumiwa@gmail.com

Changes:
  head/accessibility/qt5-speech/Makefile
  head/accessibility/qt5-speech/files/
  head/accessibility/qt5-speech/files/patch-qtspeech.pro
  head/accessibility/qt5-speech/files/patch-src_plugins_tts_tts.pro
  head/accessibility/qt5-speech/pkg-plist
Comment 5 Tobias C. Berner freebsd_committer 2019-02-24 09:31:48 UTC
Should hopefully be fixed now :)