Bug 235961 - graphics/qgis: Update to 3.6.0
Summary: graphics/qgis: Update to 3.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-23 13:29 UTC by Rainer Hurling
Modified: 2019-02-26 21:44 UTC (History)
1 user (show)

See Also:


Attachments
patch to update graphics/qgis from 3.4.3 to 3.6.0 (17.10 KB, patch)
2019-02-23 13:29 UTC, Rainer Hurling
rhurlin: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling 2019-02-23 13:29:14 UTC
Created attachment 202288 [details]
patch to update graphics/qgis from 3.4.3 to 3.6.0

This is a minor update from QGIS version 3.4.3 to 3.6.0.


Changes of the port:
- Update to 3.6.0
- Add dependency of graphics/exiv2
- Update dependency of astro/gpsbabel
- Remove doubling dependency of www/fcgi
- Remove files/patch-src_core_qgsproject.cpp,
  after it is upstream now
- Update pkg-plist


The patch is tested on Poudriere (11.2i/a, 12.0i/a, and HEADi/a),
'portlint -AC' seems happy.
Comment 1 commit-hook freebsd_committer 2019-02-26 21:14:16 UTC
A commit references this bug:

Author: swills
Date: Tue Feb 26 21:13:33 UTC 2019
New revision: 493982
URL: https://svnweb.freebsd.org/changeset/ports/493982

Log:
  graphics/qgis: Update to 3.6.0

  PR:		235961
  Submitted by:	Rainer Hurling <rhurlin@gwdg.de> (maintainer)

Changes:
  head/graphics/qgis/Makefile
  head/graphics/qgis/distinfo
  head/graphics/qgis/files/patch-src_core_qgsproject.cpp
  head/graphics/qgis/pkg-plist
Comment 2 Steve Wills freebsd_committer 2019-02-26 21:44:06 UTC
Committed, thanks!