Bug 236143 - devel/gcc8 8.3.0 build failure on FreeBSD12.0S r344618M (Feb-2019) clang 7.0.1
Summary: devel/gcc8 8.3.0 build failure on FreeBSD12.0S r344618M (Feb-2019) clang 7.0.1
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-02 06:50 UTC by dewayne
Modified: 2020-01-31 17:57 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dewayne 2019-03-02 06:50:17 UTC
The platform is a virtualbox vm, on a Windows10 64bit.  Refreshed /usr/src, build and installed world and kernel

# uname -aKU
FreeBSD FBSD12 12.0-STABLE FreeBSD 12.0-STABLE #0 r344618M: Thu Feb 28 11:27:04 AEDT 2019     root@FBSD12:/d3/F12/src/amd64.amd64/sys/GENERIC  amd64 1200503 1200503

# make __MAKE_CONF=/dev/null -C /usr/ports/lang/gcc8 -DBATCH clean package; results in

checking for long long... 8
checking size of size_t... 8
yes
checking size of long long... checking for long long... configure: error: in `/d1/ports/lang/gcc8/work/.build/libiberty':
configure: error: cannot compute sizeof (long long)
See `config.log' for more details.
yes
checking size of long long... gmake[3]: *** [Makefile:10788: configure-stage1-libiberty] Error 77
gmake[3]: *** Waiting for unfinished jobs....
8
checking for a 64-bit type... uint64_t
...
Error code 1

---
Unfortunately 12 took a lot more space to build so I needed to use ln -s /d1 /usr/ports.  Otherwise standard, note the __MAKE_CONF=/dev/null eliminates make.conf content, so its what we see.

# pkg info -a -q
binutils-2.32,1
bison-3.3.2,1
dialog4ports-0.1.6
gettext-runtime-0.19.8.1_2
gettext-tools-0.19.8.1_1
gmake-4.2.1_3
gmp-6.1.2_1
help2man-1.47.8_1
indexinfo-0.3.1
libiconv-1.14_11
m4-1.4.18_1,1
mpc-1.1.0_2
mpfr-4.0.2
p5-Locale-libintl-1.31
p5-Text-Unidecode-1.30
p5-Unicode-EastAsianWidth-1.40
perl5-5.26.3
pkg-1.10.5_5
portmaster-3.19_18
texinfo-6.5_5,1
Comment 1 Walter Schwarzenfeld freebsd_triage 2020-01-31 17:44:29 UTC
Is this stil relevant? (Seems overlooked to assign).
Comment 2 Gerald Pfeifer freebsd_committer 2020-01-31 17:57:34 UTC
I have not seen any report like this since this PR was filed, neither
from users nor any of the automation systems, and this used to be the
default version of GCC in the Ports Collection, so I am confident to
say it must have been something very specific with the local system of
the reporter.  Hence closing this without an ability to reproduce.

Should something like this happen again the future, please have a look
at the message

   See `config.log' for more details.
   
and see what the respective config.log file reveals.  Based on the error
reported, something appears be off with the bootstrapping compiler or the
environment.