Bug 236177 - Error upgrading 11.1-STABLE -> 12.0-CURRENT
Summary: Error upgrading 11.1-STABLE -> 12.0-CURRENT
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 12.0-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-03 09:37 UTC by Sergey
Modified: 2019-03-07 19:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2019-03-03 09:37:28 UTC
Hello,

I'm trying to upgrade FreeBSD from 11.1-STABLE to 12.0-CURRENT by building from source. In the middle of build process just before switching to chroot I get following error:
"UNAME_r and OSVERSION don't agree on major version number"

Same error I got when tried to upgrade from 11.3-CURRENT to 12.0-RELEASE on my T430 laptop. Then I had to reinstall OS from scratch.
Is it possible to solve the issue without OS reinstallation?

Best regards.