Bug 236285 - mail/elm+ME won't install - has plist/staging problems
Summary: mail/elm+ME won't install - has plist/staging problems
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-05 17:23 UTC by rone
Modified: 2019-08-16 06:08 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (mi)


Attachments
output of make (49.31 KB, text/plain)
2019-03-05 17:23 UTC, rone
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description rone 2019-03-05 17:23:16 UTC
Created attachment 202598 [details]
output of make

I've attached the output of Staging and Installing elm+ME-2.4.126.  I've updated both my OS and ports within the last week.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-13 19:56:49 UTC
We have version 2.5.8_5. Builds and installs fine. I close here with overcome by events.
If there are still similar problems, please reopen.
Comment 2 rone 2019-08-14 02:27:08 UTC
Yes, the elm port and pkg are at 2.5.8_5.

However, i am trying to install elm+ME, a similar but separate port.  There is no pkg for elm+ME.  The problem persists.  The listed maintainer is <johans@FreeBSD.org>.
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-14 07:30:43 UTC
I have search a time....

/usr/ports/MOVED

mail/elm+ME||2014-09-01|Not staged

The port was removed in 2014! from the ports tree.

So it is unsupported from FreeBSD.

Maybe, you will find a working version here:

http://www.elmme-mailer.org/elm-ME+2.5.html.
Comment 4 rone 2019-08-16 04:01:13 UTC
Very strange.  'portsnap fetch update' doesn't get rid of it.  Should it?

The port builds to completion; it only fails on installation.  I ended up installing the elm 2.5.8_5 pkg, then replacing the installed binaries with the built port binaries.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-16 06:08:15 UTC
Port was deleted with the following reason:

DEPRECATED: Not staged. See http://lists.freebsd.org/pipermail/freebsd-ports-announce/2014-May/000080.html

If the software remains supported/maintained upstream and someone can provide a patch to bring it up to date and in compliance with current framework guidelines, please re-open the issue.

^Triage: Assign to user that resolved