Bug 236310 - devel/sope3 Backport fix after gnustep-base update
Summary: devel/sope3 Backport fix after gnustep-base update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-06 05:28 UTC by Romain Tartière
Modified: 2019-03-07 19:31 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (acm)


Attachments
Patch to fix sope3 (1.46 KB, patch)
2019-03-06 05:28 UTC, Romain Tartière
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Romain Tartière freebsd_committer 2019-03-06 05:28:47 UTC
Created attachment 202641 [details]
Patch to fix sope3

The problem is described here:

https://sogo.nu/bugs/view.php?id=4659

The patch linked to at the end of the bug report fix the issue:

https://github.com/inverse-inc/sope/commit/2ca5842d863fd9f25593c6b608f5a1954f79d345

I think it's worth integrating it into devel/sope3 port?
Comment 1 commit-hook freebsd_committer 2019-03-07 19:28:38 UTC
A commit references this bug:

Author: acm
Date: Thu Mar  7 19:28:31 UTC 2019
New revision: 494992
URL: https://svnweb.freebsd.org/changeset/ports/494992

Log:
  - Fix problem with latest version of gnustep-base

  PR:		236310
  Submitted by:	romain
  Obtained from:	https://sogo.nu/bugs/view.php?id=4659

Changes:
  head/devel/sope3/Makefile
  head/devel/sope3/files/patch-sope-mime-NGMail_NGMailAddressParser.m
Comment 2 commit-hook freebsd_committer 2019-03-07 19:31:43 UTC
A commit references this bug:

Author: acm
Date: Thu Mar  7 19:30:43 UTC 2019
New revision: 494993
URL: https://svnweb.freebsd.org/changeset/ports/494993

Log:
  - Bump PORTREVISION. devel/sope3 was patched for fix a issue

  PR:		236310
  Reported by:	roman

Changes:
  head/www/sogo3/Makefile